Ask Your Question
0

How to increase the cell size in occupancy grid properly?

asked 2015-12-03 20:55:58 -0500

robo_explorer gravatar image

updated 2015-12-09 10:56:57 -0500

Hi,

I want to change the cell size in the occupancy grid. I changed the resolution from 0.1 to 0.5. But after this, my exploration algorithm fails at first step only. Any idea why this is happening?

I want to increase the cell size in order to decrease the number of frontiers at each step.

Image of costmap: image description

Note: I made changes in mapper.yaml not in costmap image description

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-12-04 02:30:27 -0500

It would be helpful if you could edit your question with a screenshot of the costmap you mention. With a 0.5 m cell size, there is a good chance that huge occupied cells prevent frontiers from being reachable.

edit flag offensive delete link more

Comments

Sorry for the delayed response. I have attached the screenshot of my costmap.yaml. But, I made the changes in mapper.yaml not in costmap. Do you think that can be the reason?

robo_explorer gravatar imagerobo_explorer ( 2015-12-09 10:56:00 -0500 )edit

I mean a screenshot of the actual costmap visualized in rviz, not the settings. Also, in the screenshot the resolution is set to 0.05, not 0.5 as stated in your text.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2015-12-10 02:34:10 -0500 )edit
0

answered 2016-02-02 12:40:06 -0500

When you say "I changed the resolution from 0.1 to 0.5" , you mean that you changed the resolution from 0.1 to 0.05? That's what i see in the first screenshot "resolution: 0.05".

Can you put your exploration algorithm here?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-12-03 20:55:58 -0500

Seen: 627 times

Last updated: Dec 09 '15