OpenNI no data published in the topics or rviz [closed]

asked 2013-12-29 18:26:54 -0600

daidalos gravatar image

updated 2014-01-28 17:07:24 -0600

ngrennan gravatar image

Hi i am using ros fuerte in ubuntu 12.04 on a VM. after running openni.launch, everything seems to be working normally, topics are published. However, when i run image_view or use rviz to display, no image is produced. rostopic list shows that the topic is eing published. i suspect that it might be due to no data being published in the topics and therefore results in the lack of image being produced. anyone happen to encounter this problem before and can share how to resolve this issue? i tried using the freenect stack and everything works fine. only have this issue when using the openNI stack

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-11-09 13:19:10.174957

Comments

Does openni give you any errors? Those will help diagnose your problem. And are you using the Kinect or another RGBD sensor?

Tim Sweet gravatar image Tim Sweet  ( 2014-01-02 07:12:13 -0600 )edit

sorry i am using xbox kinect model 1414. openNI runs just fine though without errors. but sometimes when i run rviz or other nodes it crashes and give the terminate error and core dumps

daidalos gravatar image daidalos  ( 2014-01-02 17:22:56 -0600 )edit

try $rostopick echo <topic_name> to sure that msgs had published

Hamid Didari gravatar image Hamid Didari  ( 2014-01-03 20:02:35 -0600 )edit

I am also facing same problem but only with Rviz (using image panel), Image_view working well. pls give the detail command used for image_view ?

lifelonglearner gravatar image lifelonglearner  ( 2014-01-29 15:51:27 -0600 )edit

@lifelonglearner I'd suggest using roswtf to diagnose your problem. I doubt your problem is related to daidalos's problem, could you start a new question and post the result of roswtf there?

Tim Sweet gravatar image Tim Sweet  ( 2014-01-29 16:32:34 -0600 )edit

@Tim Sweet I need to check roswtf i never tried earlier. Thank you for suggestion. pls see the quest. http://answers.ros.org/question/124336/rviz-not-able-to-receive-message-from-sensor_msgs-topic/

lifelonglearner gravatar image lifelonglearner  ( 2014-01-29 17:41:58 -0600 )edit