Ask Your Question
0

Setting up Catkin Baxter Environment Error - INDIGO

asked 2015-11-23 22:45:35 -0500

veyorokon gravatar image

updated 2015-11-24 06:32:52 -0500

Ubuntu 14.04.2 LTE

I'm trying to setup a workspace to simulate Baxter in gazebo with Ros Indigo. When I run catkin_make in my workspace i get the following error:

[100%] Building CXX object baxter_simulator/baxter_sim_hardware/CMakeFiles/baxter_emulator.dir/src/baxter_emulator.cpp.o

...

...

[100%] Building CXX object baxter_simulator/baxter_sim_hardware/CMakeFiles/baxter_emulator.dir/src/baxter_emulator.cpp.o
Built target kinematics
/home/veyorokon/ros/baxter_ws/src/baxter_simulator/baxter_sim_hardware/src/baxter_emulator.cpp: In member function ‘void baxter_en::baxter_emulator::publish(const string&)’:
/home/veyorokon/ros/baxter_ws/src/baxter_simulator/baxter_sim_hardware/src/baxter_emulator.cpp:284:21: error: ‘imread’ is not a member of ‘cv’
     cv_ptr->image = cv::imread(img_path, CV_LOAD_IMAGE_UNCHANGED);
                     ^
make[2]: *** [baxter_simulator/baxter_sim_hardware/CMakeFiles/baxter_emulator.dir/src/baxter_emulator.cpp.o] Error 1
make[1]: *** [baxter_simulator/baxter_sim_hardware/CMakeFiles/baxter_emulator.dir/all] Error 2
make: *** [all] Error 2
Invoking "make -j4 -l4" failed

This error has been haunting me for the past three days...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-11-24 06:31:00 -0500

I'm fairly certain that your error is related to catkin finding the wrong version of OpenCV. Do you by any chance have ros-indigo-opencv3 installed? You can check with dpkg -l |grep ros-indigo-opencv3. If it is installed, try removing with sudo apt-get remove ros-indigo-opencv3. If it is not installed, have you built OpenCV 3 from source? Or completed some other procedure to install it?

edit flag offensive delete link more
0

answered 2015-11-24 13:24:25 -0500

veyorokon gravatar image

updated 2015-11-24 14:48:56 -0500

SOLVED: opencv3 was not installed through apt. I did install it from source though. After deleting/uninstalling all versions of opencv, I went to the following link and installed it from there:

http://www.samontab.com/web/2014/06/i...

FOLLOW ALL STEPS - Including system restart.

Then i went back into the base of my workspace (baxter_ws) and ran catkin_make then i ran catkin_make install. After launch gazebo, baxter was inside and all the error messages were cleared.

edit flag offensive delete link more

Comments

Please do not add answers that are not answers. If you have new information to add, please edit your original question. You may not need to install OpenCV from source (unless you have good reason to). OpenCV 2.4 is available on Ubuntu repos, using that version is probably easiest.

jarvisschultz gravatar image jarvisschultz  ( 2015-11-24 14:08:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-11-23 22:45:35 -0500

Seen: 167 times

Last updated: Nov 24 '15