Ask Your Question
1

roslaunch dynamixel

asked 2015-10-29 06:53:31 -0500

adelleodel gravatar image

updated 2015-10-29 07:08:38 -0500

Hi again, here i'm still got problem changing my friend's ros-files electric structure and i want to changed it to indigo. i've download and install the dynamixel driver by sudo apt-get install ros-indigo-dynamixel-controllers ros-indigo-dynamixel-driver ros-indigo-dynamixel-msgs ros-indigo-dynamixel-motor and connect RS232 (for TTL) to AX12+. Now i got this error when i write roslaunch <my_package> ZMP_dynamixel.launch:

core service [/rosout] found
process[dynamixel_controller/dynamixel_manager-1]: started with pid [7803]
process[dynamixel_controller/dynamixel_controller_spawner_ax12-2]: started with pid [7804]
[INFO] [WallTime: 1446118639.239715] dynamixel_ax12 controller_spawner: waiting for controller_manager skripsi_dynamixel to startup in /dynamixel_controller/ namespace...
Traceback (most recent call last):
File "/opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py", line 245, in <module>
 manager = ControllerManager()
File "/opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py", line 102, in __init__
 serial_proxy.connect()
File "/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_serial_proxy.py", line 97, in connect
 self.dxl_io = dynamixel_io.DynamixelIO(self.port_name, self.baud_rate)
File "/opt/ros/indigo/lib/python2.7/dist-packages/dynamixel_driver/dynamixel_io.py", line 67, in __init__
 self.ser = serial.Serial(port)
File "/usr/lib/python2.7/dist-packages/serial/serialutil.py", line 261, in __init__
 self.open()
File "/usr/lib/python2.7/dist-packages/serial/serialposix.py", line 278, in open
 raise SerialException("could not open port %s: %s" % (self._port, msg))
serial.serialutil.SerialException: could not open port /dev/ttyUSB0: [Errno 13] Permission denied: '/dev/ttyUSB0'
================================================================================REQUIRED process [dynamixel_controller/dynamixel_manager-1] has died!
process has died [pid 7803, exit code 1, cmd /opt/ros/indigo/lib/dynamixel_controllers/controller_manager.py __name:=dynamixel_manager __log:=/home/adelleodel/.ros/log/8c82747c-7e1d-11e5-bae6-240a6416fc2f/dynamixel_controller-dynamixel_manager-1.log].
log file: /home/adelleodel/.ros/log/8c82747c-7e1d-11e5-bae6-240a6416fc2f/dynamixel_controller-dynamixel_manager-1*.log
Initiating shutdown!
================================================================================
[dynamixel_controller/dynamixel_controller_spawner_ax12-2] killing on exit
[dynamixel_controller/dynamixel_manager-1] killing on exit

what should i do now?

edit retag flag offensive close merge delete

Comments

2

Permission denied for device plugged in, try $ sudo chmod 777 /dev/ttyUSB0.

zweistein gravatar imagezweistein ( 2015-10-29 08:21:35 -0500 )edit

I tried it. But, it said no such file or directory

adelleodel gravatar imageadelleodel ( 2015-10-29 17:09:05 -0500 )edit
1

You should try to list all the plugged in serial communication devices ls /dev/ttyUSB* or all devices like ls /dev/*. Another way is to add the user to the group which handles that device sudo usermod -a -G groupName userName

zweistein gravatar imagezweistein ( 2015-11-02 05:59:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-03-30 06:38:39 -0500

hi, had the same problem. go to home directory, give command : chmod 777 /dev/ttyUSB0 this temporarily gives permission to execute ttyUSB0 file by all users , try executing dynamixel_manager.launch twice mine didnt work the first time

edit flag offensive delete link more

Comments

hi, thanks for replying. i had solved the problem just as you said :)

adelleodel gravatar imageadelleodel ( 2016-05-25 19:17:01 -0500 )edit

Hi, I have same problem, I use this driver, I run roslaunch dynamixel_tutorials controller_manager.launch but no morote are detected ????

Abdu gravatar imageAbdu ( 2017-10-15 15:39:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-29 06:53:31 -0500

Seen: 927 times

Last updated: Oct 29 '15