Ask Your Question
0

receiving no data from [/ardrone/navdata_gps] topic

asked 2015-10-08 05:28:39 -0500

JCUAV gravatar image

updated 2015-10-08 08:02:41 -0500

Hello,

I am working with the gps-waypoint branch of the ardrone driver. I follow the steps of the website but in the end I always get the same message (''topic [/ardrone/navdata_gps] does not appear to be published yet'') when I try to see what is being published on this topic. I already checked that the parameter "_enable_navdata_gps" is set to true.

I have no idea what the problem is. The firmware of the GPS module is the last one and I am using ROS Indigo on Ubuntu 14.04 .

Thanks in advance.

edit retag flag offensive close merge delete

Comments

How do you enable navdata_gps? Could you please specify the exact command you use to execute the driver?

Mani gravatar image Mani  ( 2015-10-08 09:16:56 -0500 )edit

$ rosrun ardrone_autonomy ardrone_driver _enable_navdata_gps:=True

I have already found the solution but thanks anyway.

JCUAV gravatar image JCUAV  ( 2015-10-09 05:37:41 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-10-09 05:33:01 -0500

JCUAV gravatar image

After using another computer I realized it was some kind of path problem. The first time I used the binary installation for the driver but the GPS branch is intalled from source. Therefore when we ran the package, the path /opt/ros/indigo/share/ardrone_autonomy was followed instead of using the files from the catkin workspace.

What I did is to unistall the ardrone_autonomy driver with the command "$ sudo apt-get --purge remove ros-indigo-ardrone-autonomy".
At this point (after running the driver again), I was able to see "/ardrone/navdata_gps" between the list of topics but when we typed "rostopic echo /ardrone/navdata_gps" we got the message "Cannot load message class for [/ardrone/navdata_gps]. Are your messages built?". The solution to this is to clean the workspace (catkin_make clean),then build it (catkin_make) and finally source the path (source devel/setup.bash).

Hopefully this is helpful.

edit flag offensive delete link more

Comments

Hi @JCUAV, I am still struggling with this. I am on ROS Kinetic running on Ubuntu 16.04. I installed the ardrone autonomy like "$apt-get install ros-kinetic-ardrone-autonomy" and then I sourced the bash file in /opt/ros/kinetic. When I launch the autonomy node, I dont see the GPS topic. Help Plz

ktiwari9 gravatar image ktiwari9  ( 2017-06-17 23:29:56 -0500 )edit

so useful!!!

Maureen gravatar image Maureen  ( 2017-07-03 14:06:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-10-08 05:28:39 -0500

Seen: 415 times

Last updated: Jul 03 '17