Ask Your Question
0

ROS Indigo on Ubuntu 14.04.03 E: Unable to locate package ros-indigo-desktop-full

asked 2015-09-11 06:08:22 -0600

ros_geller gravatar image

updated 2016-10-24 09:06:06 -0600

ngrennan gravatar image

Hi.

I am trying to install ROS Indigo on Ubuntu 14.04.03, but i keep getting this error message (for all the other install packages aswell)

E: Unable to locate package ros-indigo-desktop-full

I found several similar questions about this, but they all dated back to earlier this year. Some of them stated that indigo was not released for 14.04.03 yet, and that this release would come in May this year.

Since it is well past may, i was hoping someone had some insight as to why this is still not working?

Cheers

*edit: adding that i have followed this install tutorial to the point. http://wiki.ros.org/indigo/Installati...

I have also tried the dependency fix mentioned there, for 14.04.2, which just gave a lot more error messages about missing several other packages.

Can also add that i have installed ROS Jade without any problems at all, so there is nothing wrong with my Ubuntu distr (as far as i can tell).

**edit for new info:

$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu vivid main

$ sudo apt-get update
Ign http://dl.google.com stable InRelease
Ign http://archive.canonical.com vivid InRelease                                    
Ign http://no.archive.ubuntu.com vivid InRelease                                    
Hit http://dl.google.com stable Release.gpg                                         
Ign http://no.archive.ubuntu.com vivid-updates InRelease                            
Hit http://archive.canonical.com vivid Release.gpg                                  
Hit http://dl.google.com stable Release                                             
Ign http://no.archive.ubuntu.com vivid-backports InRelease                          
Hit http://dl.google.com stable/main amd64 Packages                                 
Hit http://archive.canonical.com vivid Release                                      
Hit http://no.archive.ubuntu.com vivid Release.gpg                                  
Get:1 http://no.archive.ubuntu.com vivid-updates Release.gpg [933 B]                
Hit http://dl.google.com stable/main i386 Packages                                  
Hit http://archive.canonical.com vivid/partner amd64 Packages                       
Hit http://no.archive.ubuntu.com vivid-backports Release.gpg                        
Hit http://no.archive.ubuntu.com vivid Release                                      
Hit http://archive.canonical.com vivid/partner i386 Packages                        
Get:2 http://no.archive.ubuntu.com vivid-updates Release [63,5 kB]                  
Ign http://security.ubuntu.com vivid-security InRelease                             
Hit http://archive.canonical.com vivid/partner Translation-en                       
Hit http://no.archive.ubuntu.com vivid-backports Release                            
Hit http://no.archive.ubuntu.com vivid/main Sources                                 
Get:3 http://security.ubuntu.com vivid-security Release.gpg [933 B]                 
Hit http://no.archive.ubuntu.com vivid/restricted Sources                           
Hit http://no.archive.ubuntu.com vivid/universe Sources                             
Hit http://no.archive.ubuntu.com vivid/multiverse Sources                           
Ign http://dl.google.com stable/main Translation-en_US                              
Hit http://packages.osrfoundation.org vivid InRelease                               
Hit http://no.archive.ubuntu.com vivid/main amd64 Packages                          
Hit http://no.archive.ubuntu.com vivid/restricted amd64 Packages                    
Get:4 http://security.ubuntu.com vivid-security Release [63,5 kB]                   
Ign http://dl.google.com stable/main Translation-en                                 
Hit http://no.archive.ubuntu.com vivid/universe amd64 Packages                      
Hit http://no.archive.ubuntu.com vivid/multiverse amd64 Packages                    
Hit http://packages.ros.org vivid InRelease                                         
Hit http://no ...
(more)
edit retag flag offensive close merge delete

Comments

Please list all the steps that you took to get to the point where you try to run sudo apt-get install ros-... This sounds like something is not correctly setup.

gvdhoorn gravatar imagegvdhoorn ( 2015-09-11 06:27:47 -0600 )edit

Did you install the additional system dependencies for 14.04.2 like suggested in Tutorial step 1.4?

RodBelaFarin gravatar imageRodBelaFarin ( 2015-09-11 06:30:29 -0600 )edit

I followed the steps in the tutorial to the point. I also tried the additional steps for 14.04.2, but this just gave a long list of additional packages it couldn't locate.

E: Unable to locate package xserver-xorg-dev-lts-utopic E: Unable to locate package mesa-common-dev-lts-utopic + 10 more

ros_geller gravatar imageros_geller ( 2015-09-11 07:47:06 -0600 )edit

Please update (edit) your question with the output of cat /etc/apt/sources.list.d/ros-latest.list and sudo apt-get update.

gvdhoorn gravatar imagegvdhoorn ( 2015-09-11 08:04:13 -0600 )edit

Updated with printouts

ros_geller gravatar imageros_geller ( 2015-09-11 09:37:12 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-09-11 09:58:37 -0600

gvdhoorn gravatar image

updated 2015-09-11 13:39:45 -0600

$ cat /etc/apt/sources.list.d/ros-latest.list
deb http://packages.ros.org/ros/ubuntu vivid main

Ubuntu Vivid is version 15.04, not 14.04 (Trusty) and there are no builds of Indigo for that version of Ubuntu (from REP 3: Target Platforms - Platforms by Distribution):

Indigo Igloo (May 2014)

  • Ubuntu Saucy (13.10)
  • Ubuntu Trusty (14.04 LTS)

So the error you got from apt-get is completely correct: there is no ros-indigo-desktop-full package installable.

Can also add that i have installed ROS Jade without any problems at all, so there is nothing wrong with my Ubuntu distr (as far as i can tell).

That is also expected: ROS Jade is released for Ubuntu Vivid (see REP 3: Target Platforms - Jade Turtle (May 2015 - May 2017)).

edit flag offensive delete link more

Comments

I, for some reason, thought I had trusty, but apparently I got vivid. That makes everything very obvious. I'm kinda new to Linux aswell, so I didn't immediately connect the dots when I saw the names and version number.

Thank you for sorting that out for me!

ros_geller gravatar imageros_geller ( 2015-09-11 12:40:32 -0600 )edit

OK.,. gvdhoorn, I read all the info you posted for this answer but I get the same issue installing Jade-Desktop-Full.. it stops me at "E: Unable to locate package ros-jade-desktop-full"... I have Trusty 14.04 installed. I have looked everywhere with no avail. Can you help me?

JohnnyQ gravatar imageJohnnyQ ( 2015-10-04 10:42:14 -0600 )edit

Oh I forgot to tell you.. this is on a MAC install of Ubuntu, which is working fine.

JohnnyQ gravatar imageJohnnyQ ( 2015-10-04 10:44:41 -0600 )edit

I think this is related to your other question, which was answered. Turned out you are trying to install ROS on an unsupported cpu architecture.

gvdhoorn gravatar imagegvdhoorn ( 2015-10-05 14:35:18 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-09-11 06:08:22 -0600

Seen: 5,747 times

Last updated: Sep 11 '15