Ask Your Question
0

Gazebo no messages from sensor

asked 2015-08-20 08:14:53 -0500

charles.fox gravatar image

I'm just trying to get a basic ROS-controlled gazebo sim with differential wheels and lidar. I have followed the gazebo tutorial and am launching from this test.launch :

<launch> <include file="$(find gazebo_ros)/launch/empty_world.launch"> <arg name="world_name" value="/home/charles/Dropbox/catkin_base/src/gazebo_ibex_gazebo/launch/ibex.world"/> </include> </launch>

Then my world file has, <include> <uri>model://my_robot</uri> </include>

And my_robot.sdf has <include> <uri>model://hokuyo</uri> <pose>0.2 0 0.2 0 0 0</pose> </include> <joint name="hokuyo_joint" type="revolute"> <child>hokuyo::link</child> <parent>chassis</parent> <axis> <xyz>0 0 1</xyz> <limit> <upper>0</upper> <lower>0</lower> </limit> </axis> </joint>

However when I run with roslaunch test.launch

I see gazebo and the robot, but there are no Hokuyo messages appearing in rostopic. Any suggestions what I'm doing wrong?

(I have tried editing hokuyo/model.sdf to <plugin name="laser" filename="libgazeboroslaser.so"> <topicname>/hokuyo_laser</topicname> <framename>map</framename> </plugin> but makes no difference)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-20 09:29:50 -0500

charles.fox gravatar image

Self answer -- I'm using ROS Indigo and its gazebo, which are using ~/.gazebo/models/hokuyo/model-1_4.sdf instead of hokuyu/model.sdf. The required change to this file is

<plugin name="laser" filename="libgazebo_ros_laser.so"/>

then it works :)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-20 08:14:53 -0500

Seen: 499 times

Last updated: Aug 20 '15