Ask Your Question
0

Gazebo4 packages installed with rosdep

asked 2015-07-13 09:15:35 -0500

Hello everyone,

Short version: Is there any way I can install gazebo4_ros related packages (msgs, plugins,ros_control and ros) with rosdep? Thank you!

Long version I want to use Gazebo 4 together with ROS Indigo. I has to manually install the gazebo4 and gazebo ROS related packages and it is working properly. However, I would like to know if there is any way to setup the package.xml of my package so that these packages are automatically installed with rosdep.

If I include

<build_depend>gazebo_ros</build_depend> 
<build_depend>gazebo_plugins</build_depend>

I get the following error when running rosdep:

 ros-indigo-gazebo-ros : Depends: gazebo2 but it is not going to be installed
                         Depends: libsdformat1 but it is not going to be installed

Which is expected because I already have Gazebo 4. And if I include

    <build_depend>gazebo4_ros</build_depend> 
    <build_depend>gazebo4_plugins</build_depend>

Then it fails because rosdep cannot find those packages.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-07-14 00:17:09 -0500

mgruhler gravatar image

updated 2015-07-14 00:18:57 -0500

As gazebo is a system dependency, you would need to add it to the rosdep definitions, which are used to lookup the respective packages.

There is a how-to about contributing rosdep rules.

But I'm not sure how this would be handled by the maintainers, as it actually introduces depedency conflicts between different packages. This is out of my league ;-)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-13 09:15:35 -0500

Seen: 105 times

Last updated: Jul 14 '15