Dropped 100.0% of messages so far

asked 2015-07-09 22:43:56 -0500

flaminga gravatar image

updated 2015-07-10 04:35:42 -0500

When i launch hector_exploration_planner, node and costmap with obstacle layer, subcribed on lazer, there is a warning:

[WARN] Messagefilter [target = map lazer]: Dropped 100.0% of messages so far. Please turn the [ros.costmap_2d.message_notifier] rosconsole logger to DEBUG for more information.

Edit 0: rqt_logger_level:(hector_exploration_node -> ros.costmap_2d.massage_filter -> DEBUG) (There isn't message.notifier)

[DEBUG]: MessageFilter [target=map lazer]: Added message in frame lazer at the time 1436512433.911, count now 50 [DEBUG] Messagefilter [target=map lazer]: Removed oldest message because buffer is full, count now 50 (frame_is=lazer, stamp = ...)

Edit 1 I found this situation here, but i run laser via hokuyo_node and i don't know, how change stamp in laser message without changing code

edit retag flag offensive close merge delete

Comments

Have you tried setting the rosconsole logger to debug, as the message suggests? (use rqt_logger_level)

ahendrix gravatar image ahendrix  ( 2015-07-09 22:59:24 -0500 )edit

It seems all is well

flaminga gravatar image flaminga  ( 2015-07-10 02:17:29 -0500 )edit

Did you reach a solution here? What is the difference between the target having only one string to the right of the equals sign and when it has two? Contrast this post to here

cmfuhrman gravatar image cmfuhrman  ( 2018-05-17 17:53:43 -0500 )edit