Ask Your Question
0

Getting started with octomap_mapping

asked 2015-06-25 20:24:23 -0500

jll gravatar image

Hello,

I am trying to learn how to use ROS and the octomap_server package. I am currently running ROS Jade, and have tried launching octomap_server several times, getting the following error:

ERROR: cannot launch node of type [octomap_server/octomap_server_node]: octomap_server

ROS path [0]=/opt/ros/jade/share/ros

ROS path [1]=/home/dso/catkin_ws/src

ROS path [2]=/opt/ros/jade/share

ROS path [3]=/opt/ros/jade/stacks

No processes to monitor

shutting down processing monitor... ... shutting down processing monitor complete

I believe this may be due to the fact that octomap_server is not yet supported for Jade? I have also tried to download octomap_mapping for Indigo using "sudo apt-get install ros-indigo-octomap ros-indigo-octomap-mapping", but I get the error message:

E: Unable to locate package ros-indigo-octomap

E: Unable to locate package ros-indigo-octomap-mapping

Am I trying to install this the correct way? And also, will I be able to run octomap_server for Indigo on Jade or will I need to use ROS Indigo instead?

Thanks in advance for the help!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-06-26 01:49:59 -0500

If octomap_server is not supported by Jade yet, then clearly that is the problem: you do not have the package installed. You can try to clone the repo in your catkin workspace and try to compile it.

If you are using Jade, just do not try to install Indigo packages.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-25 20:24:23 -0500

Seen: 539 times

Last updated: Jun 26 '15