Ask Your Question
0

PTAM is not generating executables

asked 2015-06-04 11:45:48 -0500

aland_t gravatar image

I am running Ubuntu 14.04.2 with ROS Indigo. I have the catkinized version of ethzasl_ptam installed, and catkin_make runs with no errors. When I run roslaunch ptam ptam.launch I receive the following error message: ERROR: cannot launch node of type [ptam/ptam]: can't locate node [ptam] in package [ptam] When I search the ptam directory, I see that there are no executables. In the rosbuild version of ethzasl_ptam the executables could be found in the ptam/bin directory, but this does not exist either. Any ideas?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-06-04 12:01:32 -0500

gvdhoorn gravatar image

updated 2015-06-04 12:02:06 -0500

catkin does out-of-source builds, so all binaries end up in the /path/to/workspace/devel/lib/pkg_name, not in a bin subdir of the source pkg.

Have you sourced the devel/setup.bash? Where does roscd ptam take you?

Also: how is your workspace setup?

edit flag offensive delete link more

Comments

Ahhh, roscd ptam takes me into the ptam directory. The binaries are right where you said they would be and, sourcing devel/setup.bash resulted in roslaunch working. Is there some command I can add to .bashrc, so I don't have to source devel/setup.bash every time?

aland_t gravatar image aland_t  ( 2015-06-04 12:21:06 -0500 )edit

Well you could add it to your .bashrc, see Environment Setup in the Jade installation tutorial fi.

gvdhoorn gravatar image gvdhoorn  ( 2015-06-04 13:06:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-04 11:45:48 -0500

Seen: 116 times

Last updated: Jun 04 '15