Ask Your Question
0

No GUI during calibration

asked 2014-07-29 10:03:51 -0500

updated 2014-07-30 05:05:14 -0500

I am trying to run the calibration tool of the ethzasl_ptam package, but I cannot see any GUI appearing. According to their developer's issue tracker, this problem occurs only for non-nvidia users. But I am using a Samsung NP450R4E Laptop with a NVIDIA graphics card.

Here are some greps of my OpenGL setting:

long@long:~/Workspaces/catkin$ glxinfo | grep "OpenGL version"
OpenGL version string: 4.4.0 NVIDIA 331.38
long@long:~/Workspaces/catkin$ glxinfo | grep -i opengl
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 710M/PCIe/SSE2
OpenGL core profile version string: 4.3.0 NVIDIA 331.38
OpenGL core profile shading language version string: 4.30 NVIDIA via Cg compiler
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.4.0 NVIDIA 331.38
OpenGL shading language version string: 4.40 NVIDIA via Cg compiler
OpenGL context flags: (none)
OpenGL profile mask: (none)
OpenGL extensions:

And here is the dump of roslaunch:

SUMMARY
========

CLEAR PARAMETERS
 * /cameracalibrator/

PARAMETERS
 * /cameracalibrator/ARBuffer_height: 900
 * /cameracalibrator/ARBuffer_width: 1200
 * /cameracalibrator/AutoInitPixel: 20
 * /cameracalibrator/BundleMEstimator: Tukey
 * /cameracalibrator/Calibrator_BlurSigma: 1.0
 * /cameracalibrator/Calibrator_MeanGate: 10
 * /cameracalibrator/Calibrator_MinCornersForGrabbedImage: 20
 * /cameracalibrator/Calibrator_NoDistortion: 0
 * /cameracalibrator/Calibrator_Optimize: 0
 * /cameracalibrator/Calibrator_Show: 0
 * /cameracalibrator/Cam_cx: 0.50417
 * /cameracalibrator/Cam_cy: 0.51687
 * /cameracalibrator/Cam_fx: 0.795574
 * /cameracalibrator/Cam_fy: 1.25149
 * /cameracalibrator/Cam_s: 0.482014
 * /cameracalibrator/CameraCalibrator_CornerPatchSize: 20
 * /cameracalibrator/CameraCalibrator_MaxStepDistFraction: 0.3
 * /cameracalibrator/CandidateMinSTScore: 70
 * /cameracalibrator/FASTMethod: OAST16
 * /cameracalibrator/GLWindowMenu_Enable: True
 * /cameracalibrator/GLWindowMenu_mgvnMenuItemWidth: 90
 * /cameracalibrator/GLWindowMenu_mgvnMenuTextOffset: 20
 * /cameracalibrator/ImageSizeX: 640
 * /cameracalibrator/ImageSizeY: 480
 * /cameracalibrator/InitLevel: 1
 * /cameracalibrator/MaxKF: 15
 * /cameracalibrator/MaxKFDistWiggleMult: 1
 * /cameracalibrator/MaxPatchesPerFrame: 300
 * /cameracalibrator/MaxStereoInitLoops: 4
 * /cameracalibrator/MinTukeySigma: 0.4
 * /cameracalibrator/NoLevelZeroMapPoints: True
 * /cameracalibrator/TrackerMEstimator: Tukey
 * /cameracalibrator/TrackingQualityFoundPixels: 50
 * /cameracalibrator/UseKFPixelDist: True
 * /cameracalibrator/WiggleScale: 0.1
 * /cameracalibrator/gui: True
 * /cameracalibrator/parent_frame: world
 * /rosdistro: indigo
 * /rosversion: 1.11.7

NODES
  /
    cameracalibrator (ptam/cameracalibrator)

core service [/rosout] found
process[cameracalibrator-1]: started with pid [26423]
GNU gdb (Ubuntu 7.7-0ubuntu3.1) 7.7
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <url>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<url>.
Find the GDB manual and other documentation resources online at:
<url>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /home/long/Workspaces/catkin/devel/lib/ptam/cameracalibrator...(no debugging symbols found)...done.
Starting program: /home/long/Workspaces/catkin/devel/lib/ptam/cameracalibrator image:=camera/image_raw pose:=pose __name:=cameracalibrator __log:=/home/long/.ros/log/a8fc0c54-172f-11e4-971f-24f5aa6f5f4f/cameracalibrator-1.log
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
[tcsetpgrp ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-31 03:10:02 -0500

I tried it with Bumblebee and make sure that optimus is working, but even with that I did not see any GUI appearing.

So, finally, I just pulled the the original PTAM source code. With that build, I could run the calibration tool (with GUI) and even without using optimus.

As I don't have enough Karma.. you can find some useful Links below in the comments

edit flag offensive delete link more

Comments

I got the source here: www.robots.ox.ac.uk/~gk/PTAM/ And this blog post helped me a lot to get it build (there is an include missing in the code..) http://hustcalm.me/blog/2013/09/27/ptam-compilation-on-linux-howto/

Long Hoang gravatar imageLong Hoang ( 2014-07-31 03:10:09 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-29 10:03:51 -0500

Seen: 703 times

Last updated: Jul 31 '14