Ask Your Question
0

QPainter::begin: Paint device returned engine == 0, type: 3

asked 2015-05-29 07:17:13 -0500

wsAndy gravatar image

When I want to run hector_geotiff to print map in a existed map , rosrun hector_geotiff geotiff_saver , Some thing happens.

QPainter::begin: Paint device returned engine == 0, type: 3
QPainter::setFont: Painter not active
QPainter::setPen: Painter not active
[ INFO] [1432901455.048771190]: Out drawPath
[ INFO] [1432901455.052592317]: Writing image with file /map_20:10:53.tif failed with error Device not writable
[ INFO] [1432901455.052827484]: GeoTiff created in 1.661217 seconds

I search some infomation in Internet but I haven't find a useful one.

Could you help me ?

Thanks!

Thanks!

edit retag flag offensive close merge delete

Comments

Hi i'm having the same problem, did you manage to solve it?

Nico

Nico_robotech gravatar image Nico_robotech  ( 2015-10-31 13:24:55 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2016-05-24 07:03:49 -0500

updated 2016-05-24 07:21:14 -0500

gvdhoorn gravatar image

What path are you using to save the file to? I had the same problem when I tried to reference a path with the ~ to the home directory. Possibly the program used to create the map is not able to write to this directory - someone with a better knowledge of hector_geotiff can elaborate on this. I solved this by giving the full path to the directory.

Doesn't work: <arg name = "map_file_path" value="~/maps"

Works: <arg name="/home/username/maps"

edit flag offensive delete link more

Comments

Thanks for your advice! I had solved this problem last years but I forget the detail approach. I remember that I also give the full path to the directory. I think you are right. Thanks again.

wsAndy gravatar image wsAndy  ( 2016-05-24 10:02:18 -0500 )edit
0

answered 2016-08-11 22:50:27 -0500

chengwei gravatar image

I had the same problem when I tried hector_slam [tutorial], when I run

rostopic pub syscommand std_msgs/String "savegeotiff"

I got the problem

Writing image with file /map_20:10:53.tif failed with error Device not writable

I solved this by change the file permissions. like this

sudo chmod 777 <your file="">

( http://wiki.ros.org/hector_slam/Tutor... )

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-29 07:17:13 -0500

Seen: 2,985 times

Last updated: Aug 11 '16