Ask Your Question
1

IR calibration of Asus Xtion Pro

asked 2015-05-28 04:32:47 -0500

rchacon gravatar image

I want to calibrate an Asus Xtion Pro with camera_calibration on Indigo in Ubuntu 14.04. However when I want to calibrate them using camera_calibration by typing:

ricardo@ricardo-desarrollo:~$ rosrun camera_calibration cameracalibrator.py image:=/camera/ir/image_raw camera:=/camera/ir --size 7x4 --square 0.0408

I get the following output:

('Waiting for service', '/camera/ir/set_camera_info', '...')
OK

At this point it stays eternally. With rgb camera works fine.

Thanks

edit retag flag offensive close merge delete

Comments

Does it change something when you add --no-service-check ?

Mehdi. gravatar image Mehdi.  ( 2015-05-28 05:15:55 -0500 )edit

rostopic echo /camera/ir/image_raw does show something?

Mehdi. gravatar image Mehdi.  ( 2015-05-28 06:52:04 -0500 )edit

I get the following:

WARNING: topic [/camera/ir/image_raw] does not appear to be published yet

rchacon gravatar image rchacon  ( 2015-05-28 08:21:31 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2016-04-22 11:40:10 -0500

Tones gravatar image

updated 2016-04-22 11:41:18 -0500

Try camera/ir/image instead of camera/ir/image_raw. This should work for the Asus Xtion.

edit flag offensive delete link more

Comments

Thank you very much. It works!

shyreckdc gravatar image shyreckdc  ( 2017-02-13 21:18:12 -0500 )edit
0

answered 2015-05-28 08:34:29 -0500

Mehdi. gravatar image

updated 2015-05-28 08:34:53 -0500

Do a rostopic list and find out the topic to which ir image are published, apparently it is not

/camera/ir/image_raw

edit flag offensive delete link more

Comments

Doesn't appear in list

What is happening exactly?

rchacon gravatar image rchacon  ( 2015-05-28 09:00:47 -0500 )edit

did you run roslaunch openni_launch openni.launch or whatever program you use to get your Kinect images to ROS?

Mehdi. gravatar image Mehdi.  ( 2015-05-28 09:19:16 -0500 )edit
0

answered 2015-05-28 06:24:46 -0500

rchacon gravatar image

Waiting for service doesn't appear but doesn't work, nothing happens.

edit flag offensive delete link more

Comments

you have to wait for a bit. you need to cover the projector with a note as well. Theres 1 thing though, the default parameter from factory is pretty good. When i calibrated my kinect, the parameters obtained are worse

dmngu9 gravatar image dmngu9  ( 2015-05-28 08:43:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-05-28 04:32:47 -0500

Seen: 882 times

Last updated: Apr 22 '16