Ask Your Question
0

How to improve the speed of dwa in base_local_planner? [closed]

asked 2015-05-19 22:54:44 -0600

scopus gravatar image

I am using base_local_planer as local planner. However, with same parameters, the speed of robot from Dynamic Window Approach(DWA) is smaller than with Trajectory Rollout(TR). The "max_vel_x" is set to be 2.0( m/s) ( with non-holonomic mobile model). It is easy to reach this maximum speed when controleld by Trajectory Rollout.

However, when paramer "dwa" is set to be true, the maximum value from topic /cmd_vel is about 0.25(m/s) . It is same situation when dwa_local_planner is used.

Could someone tell me how to solve this problem ? Thanks.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by scopus
close date 2015-05-20 20:14:58.945992

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-20 01:51:19 -0600

ahendrix gravatar image

Is your odometry correctly reporting the speed of the robot? If it isn't, the acceleration limit may be limiting the commanded speed.

edit flag offensive delete link more

Comments

Thank you for you attention! My project is implemented in a simulating way. Fake_localization is used for robot localization. I have checked out the source code of fake localization. It doesn't need the twist component in nav_msgs/odometry msg. So twist information is not sent to fake localization

scopus gravatar imagescopus ( 2015-05-20 08:44:08 -0600 )edit

You should implement the twist component in the odometry message.

ahendrix gravatar imageahendrix ( 2015-05-20 19:28:10 -0600 )edit
0

answered 2015-05-20 01:32:08 -0600

scopus gravatar image

I found that if the acc_lim_x is increased to 5.0 m/s^2 or more, then the speed is 0.5m/s or more. I think this is the only solution.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-19 22:54:44 -0600

Seen: 551 times

Last updated: May 20 '15