Navigation: Tuning Parameters

asked 2014-09-16 16:21:57 -0600

ROSCMBOT gravatar image

updated 2014-09-16 16:44:34 -0600

Hello,

I finally managed to set up the navigation stack on my robot. The robot only works with Odometry and IMU. No Camera or Laser. I'm using robot_localization package to fuse odom and imu data and using fake_localization instead of amcl for robot localization. The whole experiment is in simulation.

The issue I see with the robot navigation is that the global path is being generated correctly, but most of the times the robot drifts quite a bit from the global path and even go on the obstacles, and then the global planner tries to recover and generates a new global path, but the robot again deviates from the global path and hits the obstacles. On the other hand, it always manages to get to the exact pose I set as a goal point although through passing the obstacles.

I tried different values for inflation_radius parameter but didn't fix the issue. I also tried setting different inflation_radius in global_costmap_params.yaml and local_costmap_params.yaml according to this thread

Any thoughts?

Thanks

edit retag flag offensive close merge delete

Comments

With no laser, is the local_costmap empty? (no obstacles). There is a parameter, pdist_scale if you use base_local_planner, or path_distance_bias in dwa_local_planner, that makes the robot stay close to the path.

fherrero gravatar imagefherrero ( 2014-09-17 02:36:22 -0600 )edit

Have you solved your problem? I have the same one.

Dio Eraclea gravatar imageDio Eraclea ( 2015-05-26 06:53:26 -0600 )edit