ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

I can't launch a node

asked 2015-05-18 08:47:02 -0600

Porti77 gravatar image

updated 2015-05-18 08:57:38 -0600

gvdhoorn gravatar image

I created this node and when i launch it, happened this

ERROR: cannot launch node of type [nmea_navsat_driver/nmea_serial_driver]: can't locate node [nmea_serial_driver] in package [nmea_navsat_driver]

My state variables are it:

jorge_j@Ulises:~/catkin_ws$ export | grep ROS
declare -x ROSLISP_PACKAGE_DIRECTORIES="/home/jorge_j/catkin_ws/devel/share/common-lisp"
declare -x ROS_DISTRO="indigo"
declare -x ROS_ETC_DIR="/opt/ros/indigo/etc/ros"
declare -x ROS_MASTER_URI="http://localhost:11311"
declare -x ROS_PACKAGE_PATH="/home/jorge_j/catkin_ws/src:/home/jorge_j/catkin_ws/install/share:/home/jorge_j/catkin_ws/install/stacks:/opt/ros/indigo/share:/opt/ros/indigo/stacks"
declare -x ROS_ROOT="/opt/ros/indigo/share/ros"
declare -x ROS_TEST_RESULTS_DIR="/home/jorge_j/catkin_ws/build/test_results"
edit retag flag offensive close merge delete

Comments

1

Where does $ roscd nmea_navsat_driver lead you to?

BennyRe gravatar image BennyRe  ( 2015-05-18 09:54:26 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-19 09:07:20 -0600

Porti77 gravatar image

Hi all: The problem was that i copied the files with a pen drive, and lost the permission for execution and occulted files.

Thanks and regards!

edit flag offensive delete link more
2

answered 2015-05-19 08:23:37 -0600

daenny gravatar image

If the package and the source file exist, there can be a couple of reasons why it cannot locate a node.

  1. If it is Python, make sure the node file is executable

    chmod +x nmea_navsat_driver
    
  2. If it is C++, make sure it is correctly defined in your CMakelists.txt and everything is compiled correctly:

    add_executable(nmea_navsat_driver src/foo.cpp)
    
  3. Make sure that your path is setup correctly, i.e. source the correct bash file (this seems correct for your setup)

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2015-05-18 08:47:02 -0600

Seen: 825 times

Last updated: May 19 '15