Ask Your Question
0

Building cob_people_detection package on Hydro

asked 2015-05-05 07:17:06 -0500

Athria gravatar image

Hello, I'm currently running Ros Hydro on Ubuntu 12.04 and I want to use a Kinect for face recognition.

I found the cob_people_detection package and downloaded cob_people_perception-hydro_dev to my catkin_ws/src/ folder, but when I try to build it with catkin_make I get errors concerning several configuration files, like this ones:

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a configuration file for package cob_image_flip.

CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a configuration file for package cob_perception_msgs.

Here is the complete log.

I tried deleting the devel and build folders, and then building, but I get the same error. I don't have a similar problem with any of the other packages I'm using, so I'm not sure if I'm missing something here.

Thank you in advance,

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-06 07:15:51 -0500

ipa-rmb gravatar image

Ok, now I could read your log and figured out what is the problem. In addition to the cob_people_perception repository (most recent version from here: https://github.com/ipa-rmb/cob_people... ) you need to have the cob_perception_common repository. This one might be released already (i.e. can be installed via sudo apt-get install ros-hydro-cob-perception-common) but we are not releasing the latest versions on hydro anymore. Hence I suppose that even if you would have installed cob_perception_common, your version is outdated.

Please download the newest hydro version of cob_perception_common from https://github.com/ipa-rmb/cob_percep... and try to compile again.

Please notice that we will not implement future features into the hydro_dev branch anymore. For now it appeared that the indigo_dev version is working with ROS hydro successfully. So you might also give the indigo_dev branches a chance (hydro_dev and indigo_dev should be similar at the moment).

Best regards, Richard

edit flag offensive delete link more

Comments

Hello, thank you very much for your answer, I installed the missing cob_perception_common package for ros hydro and reinstalled the perception package, but I'm still getting errors, this time concerning mostly missing headers ( https://gist.github.com/Athria/141e5f... ) in lines 66, 72, etc

Athria gravatar imageAthria ( 2015-05-08 04:32:52 -0500 )edit

I also tried installing the indigo_dev like suggested, but it threw errors as well. I think I have all the dependencies for the openni2_tracker and I couldn't find anything about additional dependencies for the libnite2, but from the errors I think I might be missing something there. Thank you again

Athria gravatar imageAthria ( 2015-05-08 04:40:27 -0500 )edit
1

The errors originate from missing messages. You may solve the problem by just using one core for compilation (i.e. "catkin_make -j1") or by running catkin_make several times until everything compiles. Anyways, I have (hopefully) fixed the dependencies now, just pull and build the software again.

ipa-rmb gravatar imageipa-rmb ( 2015-05-08 06:21:43 -0500 )edit
1

Background: Catkin requires to add a line "add_dependencies(${p} ${catkin_EXPORTED_TARGETS} ${PROJECT_NAME}_generate_messages_cpp)" to run message generation from other packages before building this package when using multiple cores. I have fixed that in the hydro_dev and indigo_dev branches now.

ipa-rmb gravatar imageipa-rmb ( 2015-05-08 06:23:58 -0500 )edit

Hello, sorry but it is still trowing errors when I tried to build ( https://gist.github.com/Athria/c575b2... ), first I downloaded again both packages from github and tried with catkin_make and catkin_make -j1, since none of them worked and I couldn't fix the error I tried deleting (1/2)

Athria gravatar imageAthria ( 2015-05-11 07:36:58 -0500 )edit

other packages to see if it made any difference (I once had an issue with two conflicting packages), but it didn't help. Today I downloaded the common and perception packages once more and compiled several times, but it's still the same error. I tried deleting the devel and build folders too (2/2)

Athria gravatar imageAthria ( 2015-05-11 07:39:04 -0500 )edit
1

Looks like a SSL problem when downloading and md5sum checking sources of a library to build. You might try out two things:

  1. Open file cob_people_perception/libnite2/Makefile.tarball and comment line 8 (MD5SUM_FILE = NiTE-Linux-x64-2.2.tar.bz2.md5sum) out by putting a # before it (#MD5SUM_FILE...
ipa-rmb gravatar imageipa-rmb ( 2015-05-13 09:48:43 -0500 )edit
1

2 Just ignore those packages that give you trouble by putting an empty file with name "CATKIN_IGNORE" into the respective main folders. You do not need the following packages: libnite2, cob_people_tracking_filter, cob_openni2_tracker, cob_leg_detection. You may put CATKIN_IGNORE in all of them.

ipa-rmb gravatar imageipa-rmb ( 2015-05-13 09:51:23 -0500 )edit
0

answered 2015-05-06 06:41:35 -0500

ipa-rmb gravatar image

Hi, could you please tell me the remote address of the packages

  • cob_people_perception
  • cob_perception_common

(type git remote -v in the respective repositories)

and the branches of them (type git branch)?

We restructured a couple of things recently and I suspect that you accessed the wrong or incompatible sources.

Unfortunately, github is offline at the moment, so I cannot check your error listing. Anyways, as soon as I can access github again, I will point you to the right addresses for downloading the code.

Best regards, Richard

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-05 07:17:06 -0500

Seen: 521 times

Last updated: May 06 '15