Ask Your Question
0

cob_bringup unrecognized as a package

asked 2011-09-14 05:20:33 -0500

Paul0nc gravatar image

updated 2014-12-28 19:16:46 -0500

130s gravatar image

I am running electric on ubuntu 10.4. I installed ros-electric-care-o-bot according to the instructions. Then, following the Caro-o-bot instructions for simulation, I attempt to "rosdep install cob_bringup". I get the error below even though the cob_bringup stack is in my electric directory.

rosdep install cob_bringup
Warning: could not identify ['cob_bringup'] as a package
Usage: rosdep [options] <command> <args>
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-09-14 06:30:27 -0500

DimitriProsser gravatar image

I just downloaded and installed the Care-O-bot stack to test this problem. I was able to get the rosdep to work correctly with the following commands:

roscd cob_apps
rosdep install cob_bringup

Just a note, the rosdep for this stack only contains one dependency, and it appears that I already had it on my machine. If this turns out to be the case for you, don't panic if you see the "No packages to install" result.

I hope this helps.

edit flag offensive delete link more
0

answered 2011-09-14 11:21:13 -0500

Paul0nc gravatar image

Thanks for your reply Dimitri. I must have a more basic problem. I can see the cob_apps directory in my installation and I can see cob_bringup in that directory. However, roscd cob_apps doesn't work. If I cd to that directory, I still get the same rosdep error.

Is there an environment variable that I need to set in order for ros to recognize the care-o-bot stack?

Paul.

edit flag offensive delete link more

Comments

Has the stack been added to your ROS_PACKAGE_PATH?
DimitriProsser gravatar imageDimitriProsser ( 2011-09-14 13:46:16 -0500 )edit
Thanks again Dimitri. I added the stack to my path. rosdep works now. Did you happen to try launching the care-o-bot in simulation? Gazebo is failing when I do that. Let me know if you're interested and I'll post the failure transcript.
Paul0nc gravatar imagePaul0nc ( 2011-09-14 14:04:00 -0500 )edit
If you post it, I can take a look first thing tomorrow morning when I get to the office. You might want to consider opening a new question though, since it's a different issue. You can link to it here.
DimitriProsser gravatar imageDimitriProsser ( 2011-09-14 14:09:33 -0500 )edit
I posted a new question (not sure how to link to it). Thanks for any help you can give me. -Paul
Paul0nc gravatar imagePaul0nc ( 2011-09-14 14:26:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-14 05:20:33 -0500

Seen: 197 times

Last updated: Dec 28 '14