Ask Your Question
0

liblz4-dev not found in Debian Wheezy when trying to install Indigo on RPi2 [closed]

asked 2015-04-22 08:22:31 -0600

Craigstar gravatar image

I'm following the installation instructions for Indigo on my RPi 2, and everything is fine up until I try to install liblz4-dev using Wheezy backports. Can anyone help me resolve this issue?

$ sudo apt-get -t wheezy-backports install liblz4-dev Reading package lists... Done Building dependency tree
Reading state information... Done The following extra packages will be installed: liblz4-1 The following NEW packages will be installed: liblz4-1 liblz4-dev 0 upgraded, 2 newly installed, 0 to remove and 80 not upgraded. Need to get 49.4 kB of archives. After this operation, 167 kB of additional disk space will be used. Do you want to continue [Y/n]? y WARNING: The following packages cannot be authenticated! liblz4-1 liblz4-dev Install these packages without verification [y/N]? y Err http://http.debian.net/debian/ wheezy-backports/main liblz4-1 armhf 0.0~r114-2~bpo70+1 404 Not Found Err http://http.debian.net/debian/ wheezy-backports/main liblz4-dev armhf 0.0~r114-2~bpo70+1 404 Not Found Failed to fetch http://http.debian.net/debian/pool/ma... 404 Not Found Failed to fetch http://http.debian.net/debian/pool/ma... 404 Not Found E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I've tried update and then even checked dependecies with rosdep, and get the following (where the failure to find the python packages is expected, but not liblz4-dev). ERROR: the following rosdeps failed to install apt: command [sudo -H apt-get install -y python-catkin-pkg] failed apt: command [sudo -H apt-get install -y liblz4-dev] failed apt: command [sudo -H apt-get install -y python-rospkg] failed apt: command [sudo -H apt-get install -y python-rosdep] failed apt: Failed to detect successful installation of [python-rosdep] apt: Failed to detect successful installation of [liblz4-dev] apt: Failed to detect successful installation of [python-rospkg] apt: Failed to detect successful installation of [python-catkin-pkg]

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Craigstar
close date 2015-04-22 08:54:49.006442

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-22 08:54:28 -0600

Craigstar gravatar image

It's a little unclear, but I may have missed a key step early in the installation. I've repeated the steps and have found liblz4 is now being found and retrieved. Happy to close this query, sorry for the diversion everyone.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2015-04-22 08:22:31 -0600

Seen: 861 times

Last updated: Apr 22 '15