ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

raspberry pi with ROS Indigo ( or any new Release of ROS)

asked 2014-09-09 04:59:24 -0500

MKI gravatar image

Hi ROS Users,

The ROS community has grown tremendously over the last 2 years, and it is good to be part of this growing community. Previously I tried to install ROS (Groovy) on Raspberry Pi using this tutorial and it was successful (Debian installation). I also understand that there is Hydro Installation (installation from Source) which requires lot of time for compilation. So now My questions are,

  1. how should one proceed to install the latest version of ROS (For eg. Indigo ) on Raspberry Pi from source?
  2. how to create a ROS Indigo debian release, after installing from source (I would like to try this)?

it is also much appreciated if someone can give pointers to a debian installation of Hydro on Raspberry pi. Thanks again, and thanks to the whole community,

Best Regards,


edit retag flag offensive close merge delete


It would be nice if there was a collection of images somewhere for common hardware such as the Raspberry Pi and Beaglebone Black with Ubuntu + ROS preinstalled.

Airuno2L gravatar image Airuno2L  ( 2014-09-09 08:58:07 -0500 )edit

This has already been discussed on other topics. Turns out the cost (money and man hours) to keep this kind of images AND maintain binaries+repositories is high.

Not practical in the end. Community goals do not lean that way. (which is a nice way to say that those platforms are not that popular).

ccapriotti gravatar image ccapriotti  ( 2014-09-09 12:27:19 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted

answered 2014-10-21 09:26:54 -0500

updated 2014-10-21 16:51:26 -0500

I think I've worked out many of the problems with getting Indigo installed on the Raspberry Pi. I've written up some installation instructions here:

If you have a chance to try it out, I'd appreciate if you let me know if there are any problems and I'll try to keep it updated.

edit flag offensive delete link more


Sure, will try it out over the weekend ... thank you for the update.

MKI gravatar image MKI  ( 2014-10-21 15:00:18 -0500 )edit

@awilson Hi, Just installed bare-bones version of Indigo on Rpi, I did not overcome any problems during the installation. Truly nice work ... Thank you. Could you also leave an update as to how to install individual packages from source and also how to uninstall the same? Thanks again.

MKI gravatar image MKI  ( 2014-10-23 05:48:36 -0500 )edit

@MuraliKrishnan Great! I added a section at the end on adding individual packages to the workspace. I'm actually not sure the best way to uninstall a single package - to uninstall ros completely, you can just delete /opt/ros/indigo.

awilson gravatar image awilson  ( 2014-10-23 10:19:25 -0500 )edit

I followed it, and it works fine until step 2.2.2 (rosdep install). It fails installing python-catkin-pkg and thus dependants, saying : "python-catkin-pkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable" Of course Python is here (2.6, 2.7.3 and 3). Thanks in advance for any clue.

epascual gravatar image epascual  ( 2014-11-02 15:08:45 -0500 )edit

@epascual Hmm, I'm not sure why I didn't run into that, but I would try to install catkin_pkg using pip (sudo pip install -u catkin_pkg) and then rerun rosdep. If there's still an error, add -r to the rosdep command to ignore install errors and that may work. What variant are you installing?

awilson gravatar image awilson  ( 2014-11-02 20:29:03 -0500 )edit

@awilson Thanks a lot for your quick reply. I could bypass the problem by removing the "python:any" dependencies in /var/lib/dpkg/status and the whole process went fine. I'm installing the basic ros_comm variant. Could it be some change in the ubuntu repo the "python:any" depends clause points to?

epascual gravatar image epascual  ( 2014-11-03 02:30:38 -0500 )edit

@epascual Glad you got it working. I think python:any was very recently added and the version of apt on wheezy doesn't handle it ( ). So, your fix is fine, or it can be ignored because those packages are installed on pip.

awilson gravatar image awilson  ( 2014-11-03 13:44:44 -0500 )edit

@awilson I couldn't find any doc on the meaning of the :any suffix BTW. Maybe the procedure described in this article should mention to install these packages using pip and not letting rosdep trying to do the job. Or am I misunderstanding something ?

epascual gravatar image epascual  ( 2014-11-03 15:29:39 -0500 )edit

answered 2014-09-19 14:46:48 -0500

MKI gravatar image

updated 2014-10-07 04:59:20 -0500

Hi There,

Well, I tried this long, confusing, procedure and I was able to get Hydro on my RPi wheezy image. below are the steps I followed: (Please correct me if I did something wrong)

  1. Resizing the RPi image, well I used a 16Gb SD-card and was able to expand the file system on my Rpi hardware, using the sudo raspi-config utility. (My Idea was, to boot with as much memory as I could get).

  2. Getting the expanded RPi image on to my PC (Ubuntu 14.04). with the command sudo dd if=/dev/sdx/ of=/<path-to-my-image.img> (The Idea again is, not to use RPi hardware to perform source installation--->as it takes very long time)

  3. To boot the copied .img file in step 2 with QEMU (ARM Emulator). As mentioned in the previous answer above. (encountered a small problem here with the latest RPi image dated 09-09-2014). But I was able to boot into the RPi desktop.

  4. Following the ROS Hydro Source installation.I was able to complete the ROS installation and also could run the roscore on the QEMU terminal. (But with the exception that I was not able to install separate new packages and further steps were unsuccessful).

  5. The Last step is to get the image with ROS Hydro back onto the SD-Card with command, sudo dd if=<path-of-the-image-file-with-ROS Hydro> of=/dev/sdx ( step-2 reversed ). And ... I was NOT able to get the image run properly on Rpi hardware.

So, requesting ROS-Pi users who have already done this successfully to shed some light on this procedure, mentioned above. I spent the whole week with the emulation thing and could not get it to run on the actual hardware.

Thanks again,


UPDATE 1: I am using raspberry Pi B+ Hardware, many old distributions won't even boot on the new hardware. During the boot, I also encountered a problem of "missing kernel (ERROR) modules" with the old dist of wheezy(after performing above steps). Guess, this info might be helpful.

UPDATE 2: Hydro installation (debian) is available, I am getting dependency error when trying to perform this installation. to be more specific, I am not able to fully resolve the dependency with the command `

rosdep install --from-paths src --ignore-src --rosdistro hydro -y -r --os=debian:wheezy

` Anyone else who have done this please share your experiences. Also please let me know if you were able to do this successfully.

edit flag offensive delete link more

answered 2014-09-09 08:23:09 -0500

ccapriotti gravatar image

updated 2014-09-10 00:13:00 -0500

I have a partial answer for you, but that can come in VERY handy, especially when it comes to installing from source.

This is my personal experience, and I had limited iterations with it (tried just a few times) but worked well.

Start with a standard debian SD image; Run this image using QEMU, on a regular (powerful) computer.

Before you start, make sure you have enough space on that image. Two GB can be too small. Four GB just right for the basics. I would recommend 16 GB, if the price is right for you. Keep in mind that later you will install this image on an ACTUAL SD card.

Instead of creating an image with 16 GB, create it with 15900 MB. It is the never ending discussion about 1024 vs 1000, and sometimes the actual available space on a storage device will not be the ACTUAL reported space on the label.

There are a few tricks you have to apply in order to get your ARM image to run on a qemu environment, but it works well. download, install and compile all you want on that image

I no longer have the links that I used to create my images, but here are the key points:

  • resizing an SD image (tricky. Look into solutions that include gparted, and mounting the image as a loop device).
  • Running the image with quemu (relatively easy, but you will be "limited" to 256 MB ram)
  • transferring the final image to the SD card.

Note: I did it for Hydro. Not yet for Indigo, but it should work.


++++++++++++++++++++++++----------- LONG ADDITION -------------+++++

Well, would you look at that. I found some of my notes I meant to transform into a WIKI/HOWTO but never finished.

Before following or applying my steps, refer to the original links posted here. I recommend you understand the story rather than just repeating command lines.



SORRY FOR THIS. It was my best effort.

Well, like some people out there, I am taking my first steps in the ROS world, and my weapons of choice are a Raspberry PI (rev b, with 512 MB), an Ubuntu 12.04 running on VMWare Fusion, to be used as the "base station", and an idea in my head.

Anyone trying their luck with a RPI knows that installing ROS takes time. Some brave souls out there created images for SD card with ROS already installed, and that is a brilliant job they've done.

I had problems with those images, so I had to start my own tests.

Now, the very first obstacle was the processing power of the RPI, so, like many, I decided to go virtual, using QEMU to install and compile everything.

The other "little problem" I ran into was, the default Debian ...

edit flag offensive delete link more


Hi, Thank you for replying. The points you have mentioned do make sense, It did give me a hint as to where I should start. Will be back with results...

MKI gravatar image MKI  ( 2014-09-09 11:31:49 -0500 )edit

I had a dependency issue trying to get indigo on rasbian but hydro works fine.

tonybaltovski gravatar image tonybaltovski  ( 2014-09-09 18:56:03 -0500 )edit

@ccapriotti, you are right about the "resize operation", It is very tricky. I would like to point out here that, I am using gparted on 14.04 ubuntu (were, gparted is a GUI). it would be nice if you could elaborate a bit more on the resize operation, meaning what needs to be done when re-sizing? thnx

MKI gravatar image MKI  ( 2014-09-11 09:15:57 -0500 )edit

@MuraliKrishnan you are right. Ii was going over my notes and I realize not only it lacks details, but also that it is confusing. I mixed parted instruction with the later use I made of gparted itself. Give me a few days. I'll repeat the operation and change my post.

ccapriotti gravatar image ccapriotti  ( 2014-09-12 00:46:23 -0500 )edit

answered 2015-01-08 09:38:33 -0500

MartinHummel gravatar image

Hi, find a Raspberrry Indigo for downloading here:

edit flag offensive delete link more

Question Tools



Asked: 2014-09-09 04:59:24 -0500

Seen: 5,386 times

Last updated: Jan 08 '15