Ask Your Question
0

Beaglebone Black Rev C Debian Wheezy doesn't work with ROS?

asked 2014-05-25 02:39:35 -0500

updated 2014-05-25 02:43:37 -0500

Is ROS ready for Debian on the BBB Rev C? Looks like there are many unavailable packages still. ROScore would not run or couldn't be found. The step: "Install bootstrap dependencies" failed.

edit retag flag offensive close merge delete

Comments

Which installation instructions are you following? There are lots of debs available for Ubuntu on BBB; is installing Ubuntu an option for you?

ahendrix gravatar image ahendrix  ( 2014-05-25 07:44:03 -0500 )edit

I must have made a mistake with some command. Today it is working flawlessly for Debian. It surely takes a while to prepare the environment on the wstool init command. That little BBB CPU is hot!

Rodolfo8 gravatar image Rodolfo8  ( 2014-05-26 05:59:32 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-05-27 04:33:20 -0500

It is working fine but now I've filled up the 4 Gig eMMC with Debian and ROS. There must be a way to instruct it to install other files in the Micro SD. How does one do that? Actually I wouldn't need Gazebo and the Laser modules since I'm not planning on using them. The Micro SD is 16 Gig, so it should have plenty of room. Clearly ROS is "a piece of work!"

edit flag offensive delete link more

Comments

How did you overcome the error? : python-catkin-pkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable E: Unable to correct problems, you have held broken packages.

tsounix gravatar image tsounix  ( 2014-12-04 21:42:52 -0500 )edit
0

answered 2014-07-15 08:40:26 -0500

v.mayoral gravatar image

Rodolfo8,

I'm getting an issue on a Rev C. as well when trying to install "python-rosdep":

root@beaglebone:~# apt-get install python-rosdep Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  python-rosdep : Depends: python-catkin-pkg but it is not going to be installed
                 Depends: python-rosdistro (>= 0.3.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages. root@beaglebone:~# apt-get install python-catkin-pkg Reading package lists... Done Building dependency tree        Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies:  python-catkin-pkg : Depends: python:any (>=
2.7.1-0ubuntu2) but it is not installable E: Unable to correct problems, you have held broken packages. root@beaglebone:~# python -V Python 2.7.3
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-25 02:39:35 -0500

Seen: 919 times

Last updated: May 27 '14