ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Can"t find fedora 21

asked 2015-03-26 07:44:35 -0500

Maya gravatar image

updated 2015-03-27 04:58:29 -0500

Hello all !

Might be good information to know that I'm using the repo for here to try Ros on Fedora 21.

All was working fine before today when I tried roscore and I was hit with this error on start-up :

[malcolm@localhost ~]$ roscore
... logging to /home/malcolm/.ros/log/17102148-d3b5-11e4-9c31-dc85de5a9ca4/roslaunch-localhost.localdomain-3906.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://localhost.localdomain:60372/
ros_comm version 1.11.10


 * /rosdistro: indigo
 * /rosversion: 1.11.10


auto-starting new master
process[master]: started with pid [3917]

setting /run_id to 17102148-d3b5-11e4-9c31-dc85de5a9ca4
/opt/ros/indigo/lib/rosout/rosout: error while loading shared libraries: cannot open shared object file: No such file or directory
process[rosout-1]: started with pid [3930]
started core service [/rosout]
[rosout-1] process has died [pid 3930, exit code 127, cmd /opt/ros/indigo/lib/rosout/rosout __name:=rosout __log:=/home/malcolm/.ros/log/17102148-d3b5-11e4-9c31-dc85de5a9ca4/rosout-1.log].
log file: /home/malcolm/.ros/log/17102148-d3b5-11e4-9c31-dc85de5a9ca4/rosout-1*.log

My ROS params at start-up are :

declare -x ROSLISP_PACKAGE_DIRECTORIES="/home/malcolm/ros_ws/indigo_catkin/devel/share/common-lisp"
declare -x ROS_DISTRO="indigo"
declare -x ROS_ETC_DIR="/opt/ros/indigo/etc/ros"
declare -x ROS_MASTER_URI="http://localhost:11311"
declare -x ROS_PACKAGE_PATH="/home/malcolm/ros_ws/indigo_catkin/src:/opt/ros/indigo/share:/opt/ros/indigo/stacks"
declare -x ROS_ROOT="/opt/ros/indigo/share/ros"
declare -x ROS_TEST_RESULTS_DIR="/home/malcolm/ros_ws/indigo_catkin/build/test_results"

And I can find the named .so in

[malcolm@localhost lib]$ pwd
[malcolm@localhost lib]$ ls | grep libroscpp

All was working fine couple of days ago. So I really have no idea what happen since I don't think I did anything significant and I didn't worked on ROS lately.

I tried reinstalling it but with no luck.

I appreciate any idea or explanation on why it suddenly broke !


[malcolm@localhost ~]$ ldd /opt/ros/indigo/lib/rosout/rosout =>  (0x00007fff48749000) => not found => /lib64/ (0x00007fa96de3e000) => /lib64/ (0x00007fa96dc26000) => /lib64/ (0x00007fa96da0d000) => not found => not found => not found => /lib64/ (0x00007fa96d61b000) => /lib64/ (0x00007fa96d30a000) => not found => not found => /lib64/ (0x00007fa96d0f7000) => not found => not found => /lib64/ (0x00007fa96cef2000) => /lib64/ (0x00007fa96ccd7000) => /lib64/ (0x00007fa96cacd000) => /lib64/ (0x00007fa96c7be000) => /lib64/ (0x00007fa96c4b5000) => /lib64/ (0x00007fa96c29e000) => /lib64/ ...
edit retag flag offensive close merge delete


Can you update your post with the output of ldd /opt/ros/indigo/lib/rosout/rosout?

gvdhoorn gravatar image gvdhoorn  ( 2015-03-26 08:51:56 -0500 )edit

Here it is.

Maya gravatar image Maya  ( 2015-03-26 09:13:58 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted

answered 2015-03-27 05:07:19 -0500

Maya gravatar image

Problem solved. I'll let the solution in case someone got a similar problem.

It wasn't a ros problem (but that was to be expected). I installed another program and it changed the PATH and LD_LIBRARY_PATH variable in a wrong way (which was my fault). So that was the problem.

edit flag offensive delete link more

answered 2019-01-22 17:32:23 -0500

Haresh Miriyala gravatar image

This just happened to me. I happened to install Mujoco that changed my LD_LIBARY_PATH.

add the following lines to your bashrc file :

export PYTHONPATH="/opt/ros/kinetic/lib/python2.7/dist-packages:$PYTHONPATH"

Make sure you source the bashrc file after committing changes to ensure it works.

edit flag offensive delete link more

answered 2015-06-06 21:45:36 -0500

As it may happen to someone else... I had the same problem, the specific thing I did to reproduce this error on ubuntu 14.04 with ROS indigo on a VPS server was to do: sudo setcap cap_net_bind_service=+ep /myprogram To expose a port lower than 1024 to a program. As explained here: This disables the LD_LIBRARY_PATH variable. Which causes that shared libraries are not found.

edit flag offensive delete link more

answered 2016-07-03 19:45:27 -0500

shubh gravatar image

I had been through same problem :Which gave exactly same output error you have posted. I know that you have solved the problem, but only for maintaining a quick solution comment, I am discussing the issue back again The problem is that LD_LIBRARY_PATH has lost link to certain paths important for ros like the one mentioned in error /opt/ros/indigo/lib due to installation of some other files and libraries. So retain it you just need to add the path back again But before going for this solution do check output as shown above in posted question. If things are similar to above situation then just run this command export LD_LIBRARY_PATH=/opt/ros/indigo/lib

this had solved my problem

edit flag offensive delete link more

answered 2021-02-22 11:19:01 -0500

mobiiin gravatar image

The above problem with roscore is because the path has changed. You need to add the following to the last line of ~/.bashrc:

export LD_LIBRARY_PATH=/opt/ros/kinetic/lib

just in case this doesent work. add this line to bashrc

source /opt/ros/kinetic/setup.bash

make sure its after the other lines declaring "LD_LIBRARY_PATH" dont know the reason this has to be after that.but its in priorities and hope this gets solved soon

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2015-03-26 07:44:35 -0500

Seen: 8,994 times

Last updated: Feb 22 '21