Ask Your Question
0

OpenNI2 and ROS modules from source on NVidia Jetson TK1

asked 2015-01-09 05:49:15 -0600

Myzhar gravatar image

Hi all,

I'm porting OpenNI2 for Asus Xtion Pro Live on my robot. I succeded in compiling OpenNI2 and I can view RGB and Depth stream using rqt visualization plugin.

I wrote a guide and I published it on the website of my project: http://myzharbot.robot-home.it/blog/s...

My configuration has a problem: I cannot run "openni2_launch" correctly to get rgb pointcloud.

Am I missing something in my installation process?

edit retag flag offensive close merge delete

Comments

1

All of those packages should be available through apt if you're using the UbuntuARM repository. Why are you building them from source?

ahendrix gravatar imageahendrix ( 2015-01-09 11:28:16 -0600 )edit

Because the first time that I tried using Asus XTion Pro Live (with last kernel) I could not connect it.

Which package should I install? I saw in another thread that you are using the Asus on the Jetson...

Another doubt I have is relative to OpenCV... does ROS recognize correctly opecv4tegra?

Myzhar gravatar imageMyzhar ( 2015-01-09 11:56:12 -0600 )edit

I removed the packages and installed them from repo. The sensor works.

I noticed that it installed libopenni2 even if there is the one that I compiled by myself.

I modified launch file to activate sync and hw registration. RGB and Depth streams are ok, but pointcloud2 streams are really slow.

Myzhar gravatar imageMyzhar ( 2015-01-10 08:09:36 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-01-10 13:46:29 -0600

ahendrix gravatar image

updated 2015-01-10 13:47:55 -0600

To answer your question and comments:

In general, you should try to install packages through the package manager. This will save you time, and makes it easier to debug problems because you'll be using the exact same binaries as the rest of the community; you won't have to try to debug differences in compiler flags, build types or build flags. If you do have to install a package from source, give a short explanation of why you can't use the packaged version.

Most package managers don't recognize when you have packages installed from source, and apt is no exception. This is not an appropriate forum to discuss the reasons for this limitation; if you're really interested, do some searching and/or go read the design documentation for apt.

"Really Slow" doesn't mean anything to me; for a couple of reasons:

  • everyone has a different definition of slow and fast. 5Hz might be "fast" for me, but it's slow for someone who is used to working with 30Hz or 1000Hz data streams.
  • It doesn't capture how you're measuring the speed of the pointcloud stream.

A much better question might be "I tried to view pointclouds in rviz, and I'm only seeing them at 1-2Hz" or "I used rostopic hz to measure the speed of the pointcloud topic, and I'm only getting 8Hz". Mentioning your desired speed is also useful.

edit flag offensive delete link more

Comments

Thank you for your exhaustive reply. I tried to compile OpenNI2 and the packages to use RGB-D by myself because a few time ago I did not succeeded with the repo version. Today I used the openni2_camera, openni2_launch and rgbd_launch and they worked well.

Myzhar gravatar imageMyzhar ( 2015-01-10 15:23:53 -0600 )edit

I also solved the problem with the "speed" (only 1-2 Hz using rostopic hz /camera/depth_registered/points). The Jetson TK1 boots with only 1 core active of the 4 available. I activate them at boot and set "performance" as governor, reaching 30 hz both on the Jetson and on the remote PC using rviz wi

Myzhar gravatar imageMyzhar ( 2015-01-10 15:30:01 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-09 05:49:15 -0600

Seen: 337 times

Last updated: Jan 10 '15