Ask Your Question
1

trouble installing ros on Ubuntu

asked 2015-01-05 15:24:20 -0500

aadkinz gravatar image

updated 2015-01-05 16:48:13 -0500

William gravatar image

I'm trying to get ros set up on my Linux Machine and I've been following this tutorial

http://wiki.ros.org/indigo/Installation/Ubuntu

When I get to step 1.4 Under install where I install ROS and I go with the Desktop-Full Install which is recommended I get the following error after entering the command: sudo apt-get install ros-indigo-desktop-full

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-indigo-desktop-full : Depends: ros-indigo-simulators but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Either way I can't install it and I'm not sure why. How do I fix this?

edit retag flag offensive close merge delete

Comments

William gravatar imageWilliam ( 2015-01-05 16:49:08 -0500 )edit

@aadkinz It looks like apt-get is in a bad state, you can try sudo apt-get update && sudo apt-get dist-upgrade to resolve the issue, but that's really a shot in the dark.

William gravatar imageWilliam ( 2015-01-05 16:50:15 -0500 )edit

What platform/arch are you on?

tfoote gravatar imagetfoote ( 2015-01-05 17:11:48 -0500 )edit

Ubuntu 14.04

aadkinz gravatar imageaadkinz ( 2015-01-05 20:56:19 -0500 )edit

I also tried sudo apt-get update && sudo apt-get dist-upgrade and that didn't help

aadkinz gravatar imageaadkinz ( 2015-01-05 21:00:32 -0500 )edit

What is your hardware?

tfoote gravatar imagetfoote ( 2015-01-05 21:51:51 -0500 )edit

Do you have the universe and multiverse repositories enabled?

ahendrix gravatar imageahendrix ( 2015-01-06 00:34:13 -0500 )edit

This is my laptop I'm using a Toshiba Satellite S55B266

and ahendrix. I believe I do I'm not quite sure

aadkinz gravatar imageaadkinz ( 2015-01-06 06:18:16 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2017-09-03 12:27:29 -0500

sjsingh gravatar image

I had a similar problem of unmet dependencies. Install aptitude and run this command

sudo aptitude install ros-indigo-desktop-full

When everything is done, do check apt state by running

sudo apt-get install ros-indigo-desktop-full

It should return the following

Reading package lists... Done
Building dependency tree
Reading state information... Done
ros-indigo-desktop-full is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.

I faced this problem twice on different machines and this solved it both times. I feel apt is not well equipped to handle dependencies and aptitude does it better.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-05 15:24:20 -0500

Seen: 1,678 times

Last updated: Sep 03 '17