ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Move_base launch failed

asked 2014-12-25 11:15:30 -0500

heng gravatar image

updated 2014-12-27 08:11:21 -0500

I followed totally the same with the tutorial , but when I launch the move_base.launch, I get this error

:[FATAL] [1419514415.947186074]: Failed to create the base_local_planner/TrajectoryPlannerROS planner, are you sure it is properly registered and that the containing library is built? Exception: MultiLibraryClassLoader: Could not create object of class type base_local_planner::TrajectoryPlannerROS as no factory exists for it. Make sure that the library exists and was explicitly loaded through MultiLibraryClassLoader::loadLibrary()

This is the log:

Please help me.

I installed the navigation stack from source the problem above is solved. However, I get another error as below:

:move_base: /usr/include/eigen3/Eigen/src/Core/DenseStorage.h:69: Eigen::internal::plain_array<t, size,="" matrixorarrayoptions,="" 16="">::plain_array() [with T = float, int Size = 4, int MatrixOrArrayOptions = 0]: Assertion `(reinterpret_cast<size_t>(array) & 0xf) == 0 && "this assertion is explained here: " "" " * READ THIS WEB PAGE !!! *"' failed.

I defined both EIGEN_DONT_VECTORIZE and EIGEN_DISABLE_UNALIGNED_ARRAY_ASSERT in the move base file but the error is still occured.

edit retag flag offensive close merge delete


Please post the actual logs otherwise people can't help.

David Lu gravatar image David Lu  ( 2014-12-25 20:03:09 -0500 )edit

This is my first time post a question, I can't upload the photo so I just share the link of my log picture.

heng gravatar image heng  ( 2014-12-26 01:22:43 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-12-26 10:34:57 -0500

David Lu gravatar image

You need to make sure all of the navigation stack is installed properly.

If you installed from source, you need to include all the packages in the navigation stack/repository.

edit flag offensive delete link more


I installed the navigation stack by using sudo apt get instead from source, so I suppose it is installed properly? Or it is better to install from source?

heng gravatar image heng  ( 2014-12-27 01:23:46 -0500 )edit

apt-get is fine. Did you apt-get ros-*-base-local-planner? (where *=your distro, i.e. hydro)

David Lu gravatar image David Lu  ( 2014-12-27 11:25:23 -0500 )edit

I have updated my question. I installed it again from source and the problem solve. But another problem arises, I get an error as stated in the end part of my question. I found some answer from other question and I did the same, but it still doesn't work.

heng gravatar image heng  ( 2014-12-27 11:46:00 -0500 )edit

Question Tools


Asked: 2014-12-25 11:15:30 -0500

Seen: 630 times

Last updated: Dec 27 '14