Ask Your Question
0

error while run roscore on armel ubuntu 12.04

asked 2014-12-09 00:24:22 -0500

Alice63 gravatar image

Hello, I have installed ros groovy from source on armel ubuntu 12.04.At first,roscore can run successfully.But now,when I run roscore I got the following message:

WARNING: unable to configure logging. No log files will be generated                                                                      
Checking log directory for disk usage. This may take awhile.                                                                              
Press Ctrl-C to interrupt                                                                                                                 
Done checking log file disk usage. Usage is <1GB.                                                                                         
2;roscore                                                                                                                                 
Invalid <param> tag: Cannot load command parameter [rosversion]: command [rosversion roslaunch] returned with code [1].                   

Param xml is <param command="rosversion roslaunch" name="rosversion"/>

So I deleted the log through:$ rosclean purge Than refer to the website http://answers.ros.org/question/44996... remove the old rospkg:

 $ sudo pip uninstall rospkg

than install the latest version.$sudo pip install -U rospkg When I run roscore there is always the same message. please help me. Thank you very much.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-12-09 22:20:52 -0500

ahendrix gravatar image

This usually happens when the rosversion can't be found, or when the rosversion command can't find your ROS installation.

I would check that you've sourced the setup.bash for your ROS installation.

You can also debug a bit more by running the command in question:

rosversion roslaunch
edit flag offensive delete link more

Comments

Now,the roscore can run normally.It is really due to setup.bash. I add many ROS_PACKAGE_PATH to the setup.bash.when I deleted them the roscore can run successfully.Can not add too many ROS_PACKAGE_PATH to the setup.bash?

Alice63 gravatar image Alice63  ( 2014-12-10 07:10:12 -0500 )edit

If i add many ROS_PACKAGE_PATH,it will show: `$rosversion roslaunch

cannot locate [roslaunch]`
Alice63 gravatar image Alice63  ( 2014-12-10 07:14:02 -0500 )edit

I've never seen an instance where a user's ROS_PACKAGE_PATH was too large. What's more likely is that you're overwriting your original ROS_PACKAGE_PATH instead of appending to it, and losing the part of the path which points to the core packages.

ahendrix gravatar image ahendrix  ( 2014-12-10 12:20:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-12-09 00:24:22 -0500

Seen: 265 times

Last updated: Dec 09 '14