Ask Your Question
0

No diparity image for stereo vision using prosilica cameras

asked 2014-11-11 03:35:40 -0500

Robot gravatar image

updated 2014-11-14 01:40:52 -0500

Miquel Massot gravatar image

I have started working with two prosilica cameras for stereo vision. At first I downloaded the driver package for prosilica camera driver. I developed two launch files for two cameras in syncin1 and in fixed rate mode. Now after launching the files both the cameras are working. I have checked using rqt as well

rosrun image_view image_view image:=stereo/left/image_raw

but the topic /stereo/disparity is not showing anything. If I try to view the disparity image using

rosrun image_view disparity_view image:=stereo/disparity

it pops a window but there is nothing. Even in rqt if i go for visualization in the topic list the /stereo/disparity topic is not in the list. I am really stuck in here. Any help will appreciable.

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-11-11 09:16:59 -0500

Miquel Massot gravatar image

Hi saptarshi,

first, you have to run stereo_image_proc and then calibrate the cameras with a chekerboard, as explained here. Once the calibration has been saved (or commited), then the disparity image should be available from the topic in stereo_image_proc.

I have a similar setup (two color GigE AVT Manta sync'd), and decided to implement a new driver using the new AVT API VIMBA. The ros node is available here. I'd be very grateful if you could give it a try.

edit flag offensive delete link more

Comments

hey I have done the calibration and commit it. but still if i view the disparity image using "rosrun image_view disparity_view image:=/stereo/disparity" the pop-up window is empty. I have modified the disparity parameter as well but still it is not working.

Robot gravatar image Robot  ( 2014-11-12 04:00:40 -0500 )edit

Can you show us your launchfile?

Miquel Massot gravatar image Miquel Massot  ( 2014-11-14 01:38:25 -0500 )edit

Saptarshi, check that you are also receiving images from your right camera and that those and synchronized.

Miquel Massot gravatar image Miquel Massot  ( 2014-11-14 01:41:54 -0500 )edit
1

thanks a lot... I have checked. we have to add _approximate_sync:=True and _queue_size:=10 arguments with the stereo_view node..

Robot gravatar image Robot  ( 2014-11-14 02:45:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-11 03:35:40 -0500

Seen: 410 times

Last updated: Nov 14 '14