Ask Your Question
0

libyaml-cpp-dev cannot be installed (dependencies) [closed]

asked 2014-10-29 06:44:30 -0500

roselight gravatar image

updated 2014-10-30 09:24:01 -0500

Hi. I'm new to both, Linux and Ubuntu and am trying to install ROS-indigo following these two tutorials http://wiki.ros.org/indigo/Installati... and http://wiki.ros.org/turtlebot/Tutoria...

I keep on having and issue with the libyaml-cpp-dev package.

~$ sudo apt-get install ros-indigo-ros
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 ros-indigo-camera-calibration-parsers : Depends: libyaml-cpp-dev but it is not going to be installed
 ros-indigo-ros : Depends: ros-indigo-mk but it is not going to be installed
                  Depends: ros-indigo-rosbash but it is not going to be installed
                  Depends: ros-indigo-rosboost-cfg but it is not going to be installed
                  Depends: ros-indigo-roscreate but it is not going to be installed
                  Depends: ros-indigo-roslang but it is not going to be installed
                  Depends: ros-indigo-rosmake but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

whenever i try to fix it with sudo apt-get -f insall or try to install the libyaml-cpp-dev manualy, the following happenes

(Reading database ... 370013 files and directories currently installed.)
Preparing to unpack .../libyaml-cpp-dev_0.5.1-1_amd64.deb ...
Unpacking libyaml-cpp-dev (0.5.1-1) ...
dpkg: error processing archive /var/cache/apt/archives/libyaml-cpp-dev_0.5.1-1_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/pkgconfig/yaml-cpp.pc', which is also in package yaml-cpp 0.2.7-5precise-20120502-0513-+0000
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libyaml-cpp-dev_0.5.1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tiried removing ros and the yaml-cpp from the system, like some forum entries suggested, but nothing seems to help. I had fuerte installed before on Linux 12. recently i removed fuerte, upgraded the Linux to 14.04 and since then I'm trying to install indigo.

any ideas? :/

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by roselight
close date 2014-11-10 02:54:35.924338

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-10 02:52:45 -0500

roselight gravatar image

The problem got solved by simply reinstalling ubuntu. Apperently it didn't upgrade properly from 12.04 to 14.04. Somehow the yaml-cpp file was broken in a way, that it didn't allow me to remove or reinstall it. Many 32 Bit version programms didn't install and didn't run aswell. So it was quite a big problem.

edit flag offensive delete link more

Comments

1

I solved the problem without reinstalling, by issuing the dpgk -r yaml-cpp

Arnoud Visser gravatar imageArnoud Visser ( 2016-02-08 10:10:31 -0500 )edit

Confirmed, a sudo dpkg -r yaml-cpp fixed the problem for me, which was trying to install Indigo on a netbook I upgraded from 12.04 to 14.04. (I also had to do a sudo dpkg -r sdformat for a similar error.)

Alaina gravatar imageAlaina ( 2016-12-11 18:01:10 -0500 )edit

Question Tools

Stats

Asked: 2014-10-29 06:44:30 -0500

Seen: 859 times

Last updated: Nov 10 '14