Ask Your Question
0

libyaml-cpp error when using catkin_make on gscam

asked 2014-05-25 05:23:46 -0600

I ran across a problem, probably because I deleted one day some files related to libyaml. Anyway when I try to build gscam (ros package) I get this error.

/usr/bin/ld: warning: libyaml-cpp.so.0.2, needed by /opt/ros/hydro/lib/libcamera_calibration_parsers.so, not found (try using -rpath or -rpath-link)
/opt/ros/hydro/lib/libcamera_calibration_parsers.so: undefined reference to `YAML::Node::begin() const'

And I can't find where I could get it. I mean, I've downloaded 0.3 version from code google yaml-cpp and it works for my purposes. Any help?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-05-25 08:03:28 -0600

ahendrix gravatar image

updated 2014-05-25 09:37:58 -0600

You should be able to reinstall the yaml-cpp development library on Ubuntu by running:

On precise:

sudo apt-get install --reinstall yaml-cpp

On newer versions of Ubuntu:

sudo apt-get install --reinstall libyaml-cpp-dev
edit flag offensive delete link more

Comments

I don't have any libyaml-cpp libraries avalaible there.Only some libyaml libraries. I tried installing libyaml-dev but it didn't help.Any suggestions?

delta785 gravatar imagedelta785 ( 2014-05-25 09:15:07 -0600 )edit

I'm not sure I understand your comment; what do you mean by "I don't have any libyaml-cpp libraries avalaible there" ? Can you copy and paste the EXACT error message?

ahendrix gravatar imageahendrix ( 2014-05-25 09:19:53 -0600 )edit

output: E: Unable to locate package libyaml-cpp-dev

delta785 gravatar imagedelta785 ( 2014-05-25 09:26:02 -0600 )edit

And the output after sudo apt-get install libyam TAB TAB libyaml-0-2 libyaml-dev libyaml-shell-perl libyaml-0-2-dbg libyaml-libyaml-perl libyaml-syck-perl libyaml-appconfig-perl libyaml-perl libyaml-tiny-perl

delta785 gravatar imagedelta785 ( 2014-05-25 09:26:55 -0600 )edit

Are you running ROS on Ubuntu or a different OS?

ahendrix gravatar imageahendrix ( 2014-05-25 09:27:51 -0600 )edit

Ubuntu 12.04

delta785 gravatar imagedelta785 ( 2014-05-25 09:28:18 -0600 )edit

Ah, ok. I'm using a newer version of Ubuntu. It looks like the appropriate package on 12.04 is yaml-cpp . If you still can't find it, check to make sure that the ROS repository is still enabled.

ahendrix gravatar imageahendrix ( 2014-05-25 09:37:13 -0600 )edit

Aaaand that solved the problem. Many thanks!

delta785 gravatar imagedelta785 ( 2014-05-25 09:43:16 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-25 05:23:46 -0600

Seen: 656 times

Last updated: May 25 '14