Ask Your Question
0

cannot launch node head_pointer on pr2_surrogate, Oculus Rift dk1

asked 2014-09-30 13:05:33 -0500

Fred Eduardo gravatar image

updated 2014-11-22 17:05:53 -0500

ngrennan gravatar image

Hey Guys,

I am trying to use pr2_surrogate with oculus dk1. I get the oculus working with rviz and the kinect rendering to it, but I can't get the robot head to follow the head tracking. After I initialize robot.launch I get the following:

ERROR: cannot launch node of type [pr2_surrogate/head_pointer]: can't locate node [head_pointer] in package [pr2_surrogate] ERROR: cannot launch node of type [pr2_surrogate/arm_mover]: can't locate node [arm_mover] in package [pr2_surrogate] ERROR: cannot launch node of type [pr2_surrogate/arm_mover]: can't locate node [arm_mover] in package [pr2_surrogate]

Any ideias on what it could be?

edit retag flag offensive close merge delete

Comments

Have you built the pr2_surrogate package?

ahendrix gravatar image ahendrix  ( 2014-09-30 13:10:29 -0500 )edit

I was using catkin_make on top of ws, figured I had to do make on pr2_surrogate folder for some reason. Sorry, newbie here :)

Fred Eduardo gravatar image Fred Eduardo  ( 2014-09-30 14:48:03 -0500 )edit

hello, I have the same problem with you. Did you solve this problem? Could you tell me how?

dido_yf gravatar image dido_yf  ( 2014-12-18 04:40:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-30 14:57:45 -0500

ahendrix gravatar image

pr2_surrogate is a rosbuild package, so you should have it in a separate rosbuild workspace.

The using rosbuild with catkin tutorial explains the process in more detail.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-30 13:05:33 -0500

Seen: 71 times

Last updated: Sep 30 '14