ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

pan_tilt_port: No motors found.

asked 2018-02-20 03:42:29 -0500

epiphanyan gravatar image

updated 2018-02-20 05:31:34 -0500

gvdhoorn gravatar image

I already checked all of the parameter such as baud rate, id and USB connection etc... There is no problem! And I already tried all of the way which I can found online, but those are not useful too. I get the following error message. If you have had some experience about this problem, Please help me...

 * /dynamixel_manager/namespace: dxl_manager
 * /dynamixel_manager/serial_ports/pan_tilt_port/baud_rate: 57600
 * /dynamixel_manager/serial_ports/pan_tilt_port/max_motor_id: 25
 * /dynamixel_manager/serial_ports/pan_tilt_port/min_motor_id: 1
 * /dynamixel_manager/serial_ports/pan_tilt_port/port_name: /dev/ttyUSB0
 * /dynamixel_manager/serial_ports/pan_tilt_port/update_rate: 20
 * /rosdistro: kinetic
 * /rosversion: 1.12.12

    dynamixel_manager (dynamixel_controllers/


process[dynamixel_manager-1]: started with pid [6560]
[INFO] [1519118409.925877]: pan_tilt_port: Pinging motor IDs 1 through 25...
[FATAL] [1519118412.034350]: pan_tilt_port: No motors found.
================================================================================REQUIRED process [dynamixel_manager-1] has died!
process has died [pid 6560, exit code 1,  /opt/ros/kinetic/lib/dynamixel_controllers/ __name:=dynamixel_manager __log:=/home/jeong/.ros/log/2....../dynamixel_manager-1.log].
log file: /home/jeong/.ros/log/...../dynamixel_manager-1*.log
Initiating shutdown!
[dynamixel_manager-1] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
edit retag flag offensive close merge delete


What dynamixels are you running? and have you tried the dynamixel_motor package I found the dynamixel_controllers one to be unreliable with the AX12 dynamixel

Peter Heim gravatar image Peter Heim  ( 2018-02-20 05:19:30 -0500 )edit

Thanks for your reply. I already tried that, but It is still not working. My motor is MX-106

epiphanyan gravatar image epiphanyan  ( 2018-02-20 05:23:12 -0500 )edit

Hello :)

ROBOTIS provides official opensource repository as ROBOTIS-GIT?

In this repository, you can find Dynamixel-Workbench to control all series of DYNAMIXELS. Because it is official package for DYNAMIXEL, you can get a proper solution when you faced some problems.

This is WIKI page for DYNAMIXEL and introduced packages.


WIKI for Dynamixel-Workbench

Enjoy with it!


Darby Lim gravatar image Darby Lim  ( 2018-02-22 00:02:13 -0500 )edit

I believe that this should be a comment instead of an answer as this doesn't answer the question. Instead, it just points to a wiki and GitHub repo.

jayess gravatar image jayess  ( 2018-02-22 00:33:02 -0500 )edit

did you end up resolving this?

RobotRob gravatar image RobotRob  ( 2018-03-28 15:33:39 -0500 )edit

I'm also trying to interface moveit to my real robot i.e RCS-6. I'm using hubby HS422 servo motor. I tried dynamixel_motor pkg but i also got the same error. Can i use dynamixel_motor pkg for my servo motor?

Ravi_Kanth gravatar image Ravi_Kanth  ( 2018-06-18 05:09:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2019-06-17 21:29:06 -0500

tomarRobin gravatar image

There are possibly three reasons due to which this can occur

  1. Either the id is more than the set range
  2. Or the baud rate is different
  3. the motor's firmware is not working properly

try this :

  • check the id of motor using single manager gui package from dynamixel workbench and confirm it is not set to be more than 25.
  • check the communication baud rate it should match 57600
    • if both of the above are fine then do a firmware recovery using R+ manager
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-02-20 03:33:30 -0500

Seen: 1,153 times

Last updated: Feb 22 '18