Ask Your Question
0

Cannot plot turtle pose in rqt_plot

asked 2014-09-13 08:27:41 -0500

kost9 gravatar image

Hi All! I am just starting to learn ROS. So I was following the tutorial on understanding TOPICS ( http://wiki.ros.org/ROS/Tutorials/Und... ), where I was supposed to run $ rosrun rqt_plot rqt_plot and enter /turtle1/pose/x in GUI, but I keep getting this message in the terminal:

    Traceback (most recent call last):   File "/opt/ros/hydro/lib/python2.7/dist-packages/rqt_plot/plot_widget.py", line 204, in on_topic_edit_textChanged
        plottable, message = is_plottable(topic_name)   File "/opt/ros/hydro/lib/python2.7/dist-packages/rqt_plot/plot_widget.py", line 104, in is_plottable
        fields, message = get_plot_fields(topic_name)   File "/opt/ros/hydro/lib/python2.7/dist-packages/rqt_plot/plot_widget.py", line 75, in get_plot_fields
        field_class = topic_helpers.get_type_class(slot_type) AttributeError: 'module' object has no attribute 'get_type_class'
AttributeError: 'module' object has no attribute 'get_type_class'

I ran roswtf and got this :

Loaded plugin tf.tfwtf
No package or stack in context
================================================================================
Static checks summary:

Found 1 error(s).

ERROR Not all paths in PYTHONPATH [/home/omar/catkin_ws/devel/lib/python2.7/dist-packages:/opt/ros/hydro/lib/python2.7/dist-packages] point to a directory: 
 * /home/omar/catkin_ws/devel/lib/python2.7/dist-packages

================================================================================
Beginning tests of your ROS graph. These may take awhile...
analyzing graph...
... done analyzing graph
running graph rules...
... done running graph rules

Online checks summary:

No errors or warnings

I can't get any plots described in tutorials, so I was hoping you could help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-13 11:56:01 -0500

ahendrix gravatar image

Are you sure you have up-to-date versions of all of the ROS packages? Try running apt-get update and apt-get upgrade.

edit flag offensive delete link more

Comments

I was having a somewhat similar issue and this (along with restarting my computer) seemed to help, thanks!

JMarple gravatar imageJMarple ( 2014-09-13 15:01:23 -0500 )edit

Thank you, that helped!

kost9 gravatar imagekost9 ( 2014-09-15 00:25:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-09-13 08:27:41 -0500

Seen: 248 times

Last updated: Sep 13 '14