Ask Your Question
0

How can I get both tf and tf2 working in ROS

asked 2014-09-02 13:30:55 -0500

DrBot gravatar image

updated 2014-09-02 13:35:49 -0500

-- +++ processing catkin package: 'tf' -- ==> add_subdirectory(geometry/tf) CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package): Could not find a configuration file for package angles.

Set angles_DIR to the directory containing a CMake configuration file for angles. The file will have one of the following names:

anglesConfig.cmake
angles-config.cmake

Call Stack (most recent call first): geometry/tf/CMakeLists.txt:7 (find_package)

-- tf: 1 messages, 1 services -- +++ processing catkin package: 'tf_conversions' -- ==> add_subdirectory(geometry/tf_conversions) -- Eigen found (include: /usr/include/eigen3) -- Configuring incomplete, errors occurred! make: * [cmake_check_build_system] Error 1 Invoking "make cmake_check_build_system" failed ubuntu@ubuntu-armhf:~/catkin_ws$ sudo aptitude install ros-hydro-tf No candidate version found for ros-hydro-tf

I have a working version on BBB where I see both tf and tf2* in /opt/ros/hydro/share. I have a non working version with no tf in share. how do I build or install tf so it either get's to share or is built in a catkin workspace? I have geometry built in the carkin workspace - and it list tf as being there.

edit retag flag offensive close merge delete

Comments

1

As of hydro tf uses tf2 under the hood. There should be no conflict between them.

tfoote gravatar imagetfoote ( 2014-09-02 15:33:56 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-09-02 13:38:28 -0500

ahendrix gravatar image

The cmake error you posed indicates that you don't have the angles package installed. Have you tried installing it?

sudo apt-get install ros-hydro-angles

More generally, if you have a workspace where the dependencies may be missing, you can usually install them with rosdep:

rosdep install --from-paths src -i
edit flag offensive delete link more
0

answered 2014-09-03 09:53:41 -0500

DrBot gravatar image

updated 2014-09-04 16:31:39 -0500

Thanks Austin and Tully, your answers fixed most of my issues.I now have a working uvc_camera. I still seem to be missing a dependency in sensor-msgs, though as far as I can tell it is installed(git clone of common-msgs in the catkin_ws).

I did a complete fresh install on a 12.04 bbb.

still get:

ubuntu@ubuntu-armhf:~/catkin_ws$ rosdep install --from-paths src -i executing command [sudo apt-get install ros-hydro-tf] Reading package lists... Done Building dependency tree Reading state information... Done Package ros-hydro-tf is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source

E: Package 'ros-hydro-tf' has no installation candidate ERROR: the following rosdeps failed to install apt: command [sudo apt-get install ros-hydro-tf] failed

aptitude install of ros-hydro-navigation also fails like this:

The following packages are RECOMMENDED but will NOT be installed: dbus 4 packages upgraded, 279 newly installed, 0 to remove and 23 not upgraded. Need to get 144 MB of archives. After unpacking 522 MB will be used. The following packages have unmet dependencies: ros-hydro-navfn : Depends: ros-hydro-tf which is a virtual package. ros-hydro-fake-localization : Depends: ros-hydro-tf which is a virtual package. ros-hydro-costmap-2d : Depends: ros-hydro-tf which is a virtual package. ros-hydro-pcl-ros : Depends: ros-hydro-tf which is a virtual package. ros-hydro-dwa-local-planner : Depends: ros-hydro-tf which is a virtual package. ros-hydro-carrot-planner : Depends: ros-hydro-tf which is a virtual package. ros-hydro-laser-geometry : Depends: ros-hydro-tf which is a virtual package. etc.

edit flag offensive delete link more

Comments

You should be able to install sensor_msgs from debs: sudo apt-get install ros-hydro-sensor-msgs. In fact, you should NEVER have to install a core package like sensor_msgs from source unless you're doing the whole build from source.

ahendrix gravatar imageahendrix ( 2014-09-03 12:34:00 -0500 )edit

According to the ARM status page, you should also be able to install uvc_camera from debs: sudo apt-get install ros-hydro-uvc-camera

ahendrix gravatar imageahendrix ( 2014-09-03 12:35:51 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-02 13:30:55 -0500

Seen: 1,945 times

Last updated: Sep 04 '14