Ask Your Question
0

Is it possible to disable the local planner in Rviz?

asked 2014-07-10 21:53:05 -0600

JJ gravatar image

Hello,

I want to know if it's possible to simply disable the local planner in Rviz.

I'm trying to implement turtlebot navigation - autonomously navigate in a known map, but for some reason, the local planner seems to be ignoring the costmap, causing the robot to collide with obstacles. The global planner works perfectly; it finds the shortest distance path based on the given map with no collisions with obstacles. I'm wondering if there's a way for me to just disable the local planner in Rviz so that the robot moves strictly according to the global planner, which should suffice for my purpose now?

Or if people have an idea of what's going wrong that's also welcomed =)

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-07-10 23:45:35 -0600

Hi JJ,

I think you have a slight misconception of what Rviz is, Rviz is a visualisation and interaction tool, it is in no way in charge of the algorithms underneath the navigation framework.

Once clarified that, take a look at the documentation of the navigation stack. If the global planner works well, it might be possible that you are not defining properly the radius of the robot or its footprint or the inflation radius of the obstacles, causing the local planner to generate paths that end up in collision.

It might also be that the obstacles go out of the field of view of your sensor (probably a Kinect?) when they are relatively close to the robot (<20cm) and the local planer is clearing them out of the costmap (because the robot doesn't see them any more).

Good luck!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-07-10 21:53:05 -0600

Seen: 203 times

Last updated: Jul 10 '14