Ask Your Question
0

Sicktoolbox_wrapper not compatible with sick lms111? [closed]

asked 2014-06-30 16:10:40 -0600

randylewis7 gravatar image

updated 2015-08-18 01:33:18 -0600

ahendrix gravatar image

Hello, I have a sick lms111 laser scanner that I am trying to set up with ros. After some research online, I have found the sicktoolbox and the ros sicktoolbox wrapper, and I would like to use these if possible to interface with my device because I have no idea how to write these kind of drivers/wrappers by myself. I installed sicktoolbox from here:

http://sourceforge.net/projects/sickt... , and tried to use this tutorial to configure it properly:

http://sicktoolbox.sourceforge.net/do... .

Then, I installed the sicktoolbox wrapper (using sudo apt-get install ros-hydro-sicktoolbox-wrapper), and am trying to follow this tutorial to use it with my device:

http://wiki.ros.org/sicktoolbox_wrapp... .

However, when I try to run the line in section 1.6:

rosrun sicktoolbox_wrapper sicklms,

I get the error:

sickLMS2xx::_setupCOnnection - unable to open serial port error: initialize failed! are you using the correct device path?

At this point I noticed that the error says sick lms 2xx, and i am using the sick lms 1xx. Is this the problem? If not, will this be a problem in the future? It seems weird to have a package that is only compatible with the 200 versions of sick LMS scanners and not the 100 versions, since I imagine they're remarkably similar. However, if this really is the case, does anyone know of any other way for me to interface with my lms111 through ROS?

Thanks a lot,

Randy

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by randylewis7
close date 2014-07-07 11:09:24.193735

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-07-01 23:33:21 -0600

edit flag offensive delete link more

Comments

Yeah I tried that package but haven't been able to get it to work. After downloading it, I find a cmake directory, a launch directory, and a package.xml file. I have tried to do something with the CMake file, but I don't understand ("cmake <the cmake="" folder="" or="" either="" of="" the="" configuration="" cmake="" files="" inside="">" doesn't work). I've also tried to run the LMS100 launch file inside the launch file directory, but I get the error "error: cannot launch node of type [LMS1xx/LMS1xx_node], presumably because I also can't find the actual node anywhere in the downloaded folder. I downloaded it using sudo apt-get install ros-hydro-lms1xx. ANy idea what I' doing wrong?

randylewis7 gravatar imagerandylewis7 ( 2014-07-03 12:48:03 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-06-30 16:10:40 -0600

Seen: 532 times

Last updated: Jul 01 '14