Ask Your Question
2

Problems installing Hydro on 12.04 from source on armhf

asked 2013-10-07 00:51:35 -0500

updated 2014-04-20 14:09:36 -0500

ngrennan gravatar image

Hi I'm having a dependency issue trying to install Hydro on 12.04 from source. I get an error:

E: Unable to locate package python-wstool

after the part:

sudo apt-get install python-rosdep python-rosinstall-generator python-wstool build-essential

I was getting the same error but for all the dependencies, however that was resolved by apt-get update command.

Any suggestions. This is going onto an ARM device with 12.04 installed and did have fuerte installed.

EDIT I found and followed this option to use pip to install wstools instead. However now getting the following error:

     Found existing installation: rospkg 1.0.18
    Uninstalling rospkg:
      Successfully uninstalled rospkg
  Running setup.py install for rospkg
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
    ImportError: No module named setuptools
    Complete output from command /usr/bin/python -c "import setuptools;__file__='/home/ubuntu/build/rospkg/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /tmp/pip-65brKO-record/install-record.txt:
    Traceback (most recent call last):

  File "<string>", line 1, in <module>

ImportError: No module named setuptools

----------------------------------------
  Rolling back uninstall of rospkg
Command /usr/bin/python -c "import setuptools;__file__='/home/ubuntu/build/rospkg/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /tmp/pip-65brKO-record/install-record.txt failed with error code 1
Storing complete log in /home/ubuntu/.pip/pip.log

EDIT Okay needed to install setuptools as per the directions here.

came up with a new error ends with:

ImportError: No module named pkg_resources

EDIT Okay theres a happy ending to this story however there seems to be a degree of luck in achieving it, so I am happy if someone can improve this.

First I purged and removed python-pkg-resources, this is the part that seems most dodgy:

sudo apt-get remove --purge python-pkg-resources

and then reinstalled it:

sudo apt-get install python-pkg-resources python-nose python-pip python-setuptools

Things were a bit broken (eggs) but this seemed to do the trick.

sudo pip install --upgrade setuptools

after which the pip install command worked:

sudo pip install -U wstool

EDIT

Well it actually didn't work when I went to deal with the installation of rosdep. there were unmet dependencies which may have resulted directly from using pip to install wstools.

A full reinstall of ubuntu didn't work either, apt-get still cant find python-wstools.

EDIT

I reused pip to install rosdep, wstools and rosinstall_generator, and was able to download the source packages, but when executing the command:

rosdep install --from-paths src --ignore-src --rosdistro hydro -y

It would download and unpack dependencies for a couple of hours then stop on error:

executing command [sudo apt-get install -y python-rospkg]
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package python-rospkg is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-rospkg' has no installation candidate
ERROR: the following rosdeps failed to install
  apt: command [sudo ...
(more)
edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
2

answered 2013-10-09 15:04:09 -0500

The solution: First need to download and install setuptools and extract.

Enter the extracted folder and run:

$ sudo python setup.py install

Now install stdeb as per the instructions for self install.

Create the python dependencies:

$ pypi-install rosdep
$ pypi-install rosinstall-generator
$ pypi-install wstools
$ sudo apt-get install build-essential

Continue with the hydro installation till all source folders have been installed and your ready to use rosdep to install dependencies

Now there is an issue with collada-dom-dev dependencies and assimp (has been since Fuerte, Groovy) follow the instructions on sysadminfixes to install. See the sections on Fix Missing Dependencies For Collada Packages .

Continue the ros-hydro install as listed in the hydro source installation guide to install dependecies and build workspace.

Acknowledgements

Thanks to William (+1) for identifying stdeb, that really was the key to resolving these python dependencies. Also sysadmin fixes has a number of workarounds for various things if you get stuck but primarily for beagle based boards

This was for a minimal armhf install on Ubuntu 12.04 running on a beaglebone white.

edit flag offensive delete link more
1

answered 2013-10-08 01:46:38 -0500

4LV4R0 gravatar image

My answer will not help you at all but I´ll give you an "up" to this topic.

But after trying to install Groovy without success I´m trying to install Hydro and I´m getting the same issue with this.

I´m not with Ubuntu. I´m trying it on a Raspberry running Raspbian.

Any help would be really appreciated.

Thanks

edit flag offensive delete link more

Comments

On the hydro source installation page, Ahendrix alludes to a missing dependency in lisp (python?) preventing the build. I think the packages above are some of the missing dependencies. My understanding is that these dependencies are outside ROS. There's probably little to do but wait?

PeterMilani gravatar imagePeterMilani ( 2013-10-08 02:08:05 -0500 )edit

My problem is that I´m in a hurry :S beacuse we need it for an University Project... so our patience is running out :(

4LV4R0 gravatar image4LV4R0 ( 2013-10-08 02:12:26 -0500 )edit

May be @ahendrix can give feedback about the state of the current ARM packages.

Dirk Thomas gravatar imageDirk Thomas ( 2013-10-08 07:13:06 -0500 )edit
1

answered 2013-10-08 07:49:25 -0500

William gravatar image

updated 2013-10-08 07:52:42 -0500

It looks like the issue is that there aren't debs for these python tools in the armhf debian repository. These packages are architecture independent so you should be able to install them from source. If the problem is that other packages depend on them, then you can try using checkinstall to make a fake deb for them:

$ cd /path/to/rosdep_source
$ sudo checkinstall python setup.py install

This should ask you some questions, you should try to make sure the name of the deb becomes python-rosdep.

EDIT

Another option is that you can use stdeb (like we do) to package it for armhf? I'm not sure what exactly would be required for this, but you can read up about stdeb here:

https://github.com/astraw/stdeb

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-10-07 00:51:35 -0500

Seen: 2,646 times

Last updated: Oct 09 '13