Ask Your Question
0

ROS Sensors Driver Android Application Issue

asked 2014-04-07 11:42:29 -0500

musik gravatar image

updated 2016-10-24 09:00:13 -0500

ngrennan gravatar image

I am trying to use the ROS Sensors Driver application for android devices, but have been unsuccessful in my attempts to get the app to work. Does the android_sensors_driver work on a virtualbox version of ubuntu running ROS? I have followed the directions exactly how they are stated here: http://wiki.ros.org/android_sensors_d... but I am not able to successfully get ROS to recognize android-sensors-driver as a node. According to the virtualbox wired connection, my IP address is 10.0.2.15. I have tried the following

http://10.0.2.15:11311/
http://ROS:11311/ because ROS is displayed when roscore is running
http://10.0.2.2:11311/ because of a suggestion on an online forum

but nothing seems to work. Any guidance would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

Can you include the exact commands you're running and the error output you're seeing in your question?

ahendrix gravatar imageahendrix ( 2014-04-07 11:54:23 -0500 )edit

The terminal now recognizes the sensor drivers When I test individual node connectivity: viki@ROS:~$ rosnode ping /android_sensors_driver_imu rosnode: node is [/android_sensors_driver_imu] pinging /android_sensors_driver_imu with a timeout of 3.0s unknown network error contacting node: timed out

musik gravatar imagemusik ( 2014-04-10 11:18:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-04-07 11:53:17 -0500

Chad Rockey gravatar image

You need to forward port 11311 to the virtual machine.

http://www.howtogeek.com/122641/how-t...

After you do that, you need to connect to your HOST machine's IP:11311. http://HOST_IP_HERE:11311/

edit flag offensive delete link more

Comments

Thanks! I'm now trying to test the connectivity of the nodes but I'm getting the following: viki@ROS:~$ rosnode ping /android_sensors_driver_imu rosnode: node is [/android_sensors_driver_imu] pinging /android_sensors_driver_imu with a timeout of 3.0s unknown network error contacting node: timed out

musik gravatar imagemusik ( 2014-04-10 10:19:43 -0500 )edit

Also should my ROS_MASTER_URI also be http://HOST_IP_HERE:11311/ ? Do I change it as well or leave it as it is? Whenever I change that parameter to include the host ip, I get the following: ROS_MASTER_URI [http://.......:11311/] host is not set to this machine

musik gravatar imagemusik ( 2014-04-10 12:06:26 -0500 )edit

Hmmm that is tricky. You can probably get around this by using hostnames for launching roscore and setting ROS_IP=HOST_IP. For instance, ROS_MASTER_URI=http:://virtual-machine-name:11311/; ROS_IP=HOST_IP; roscore. Then connect via android using MASTER_URI=http://HOST_IP:11311/

Chad Rockey gravatar imageChad Rockey ( 2014-04-10 12:26:34 -0500 )edit

Sorry for the newb question, but when you say "virtual-machine-name" are you referring to the name given according to the initial VirtualBox start menu, which in my case would be "ROS Groovy Galapagos"?

musik gravatar imagemusik ( 2014-04-14 18:20:55 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-07 11:42:29 -0500

Seen: 1,125 times

Last updated: Apr 07 '14