Ask Your Question
0

Asus Xtion on BeagleBone Black

asked 2014-04-05 18:13:08 -0600

Maeth gravatar image

I am working with the BeagleBone Black and Asus Xtion Pro Live.

(lsusb gives device ID 1d27:0600, exactly what I expect)

I have installed Ubuntu 12.04 (hard floating point edition for BeagleBoneBlack), and ROS Hydro. After installing all the prerequisites, I built the OpenNI and Sensor software packages. I can navigate to ~/OpenNI/Platform/Linux/Bin/Arm-Release, and run some of the samples, and they work fine. For example, running Sample-NiSimpleRead returns me distance at roughly 30Hz

However, when I try to roslaunch openni_launch, I get nothing. No error messages, no reports of problems connecting to USB. Just no data coming out. The cluster of nodes starts publishing a bunch of TF messages, and they seem to be what is desired. However, I get no other rostopics published.

I have tried to use Openni2 launch and camera, but they refuse to build because they say they can't find libopenni2 (even though I built and installed openni2.2 as well)

Here is what I get: ubuntu@ubuntu-armhf:~/catkin_ws$ roslaunch openni_launch openni.launch --screen ... logging to /home/ubuntu/.ros/log/2eca5c12-bd41-11e3-a675-c8a030a9e305/roslaunch-ubuntu-armhf-1039.log Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt Done checking log file disk usage. Usage is <1GB.

started roslaunch server (COMMENTED OUT DUE TO LOW KARMA)

SUMMARY

PARAMETERS * /camera/camera_nodelet_manager/num_worker_threads * /camera/depth_rectify_depth/interpolation * /camera/depth_registered_rectify_depth/interpolation * /camera/disparity_depth/max_range * /camera/disparity_depth/min_range * /camera/disparity_registered_hw/max_range * /camera/disparity_registered_hw/min_range * /camera/disparity_registered_sw/max_range * /camera/disparity_registered_sw/min_range * /camera/driver/depth_camera_info_url * /camera/driver/depth_frame_id * /camera/driver/depth_registration * /camera/driver/device_id * /camera/driver/rgb_camera_info_url * /camera/driver/rgb_frame_id * /rosdistro * /rosversion

NODES /camera/ camera_nodelet_manager (nodelet/nodelet) debayer (nodelet/nodelet) depth_metric (nodelet/nodelet) depth_metric_rect (nodelet/nodelet) depth_points (nodelet/nodelet) depth_rectify_depth (nodelet/nodelet) depth_registered_rectify_depth (nodelet/nodelet) disparity_depth (nodelet/nodelet) disparity_registered_hw (nodelet/nodelet) disparity_registered_sw (nodelet/nodelet) driver (nodelet/nodelet) points_xyzrgb_hw_registered (nodelet/nodelet) points_xyzrgb_sw_registered (nodelet/nodelet) rectify_color (nodelet/nodelet) rectify_ir (nodelet/nodelet) rectify_mono (nodelet/nodelet) register_depth_rgb (nodelet/nodelet) / camera_base_link (tf/static_transform_publisher) camera_base_link1 (tf/static_transform_publisher) camera_base_link2 (tf/static_transform_publisher) camera_base_link3 (tf/static_transform_publisher)

auto-starting new master process[master]: started with pid [1052] ROS_MASTER_URI=(COMMENTED OUT DUE TO LOW KARMA)

setting /run_id to 2eca5c12-bd41-11e3-a675-c8a030a9e305 process[rosout-1]: started with pid [1065] started core service [/rosout] process[camera/camera_nodelet_manager-2]: started with pid [1077] process[camera/driver-3]: started with pid [1089] process[camera/debayer-4]: started with pid [1117] process[camera/rectify_mono-5]: started with pid [1131] Warning: USB events thread - failed to set priority. This might cause loss of data... process[camera/rectify_color-6]: started with pid [1146] process[camera/rectify_ir-7]: started with pid [1160] process[camera/depth_rectify_depth-8]: started with pid [1174] process[camera/depth_metric_rect-9]: started with pid [1188] process[camera/depth_metric-10]: started with pid [1202] process[camera/depth_points-11]: started with pid [1216] process[camera/register_depth_rgb-12]: started with pid [1230] process[camera/points_xyzrgb_sw_registered-13]: started with pid [1244] process[camera/depth_registered_rectify_depth-14]: started with pid [1258] process[camera/points_xyzrgb_hw_registered-15]: started with pid [1272] process[camera/disparity_depth-16]: started with pid [1286] process[camera/disparity_registered_sw-17]: started with pid [1300] process[camera/disparity_registered_hw-18]: started with pid [1314] process[camera_base_link-19]: started with pid [1328] process ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-04-07 04:45:53 -0600

paulbovbel gravatar image

Just so you know, you have an older version of the Xtion (0600), so you SHOULD be using openni(1) launch and camera. Openni2 only worked properly (for me) for the newer Xtion (0601).

The setup is definitely finicky in regards to your usb controller and kernel version, so you could try fiddling around with the settings in /etc/openni/GlobalDefaults.ini.

edit flag offensive delete link more

Comments

@paulbovbel How well does the Beaglebone black handle the xtion data? Is it capable of 30 fps?

tonybaltovski gravatar imagetonybaltovski ( 2014-04-07 09:24:03 -0600 )edit

I never used it with the beaglebone, but almost certainly not.

paulbovbel gravatar imagepaulbovbel ( 2014-08-10 16:23:55 -0600 )edit
0

answered 2014-04-07 14:41:16 -0600

Maeth gravatar image

"For example, running Sample-NiSimpleRead returns me distance at roughly 30Hz"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-04-05 18:13:08 -0600

Seen: 648 times

Last updated: Apr 07 '14