Ask Your Question
0

"node name cannot contain namespace"

asked 2014-03-04 01:12:32 -0500

Yannik_K gravatar image

updated 2014-03-04 05:49:04 -0500

Hello

When I try to open a generated moveit_config (I also have an other question about this Issue on this forum) I get an error that says that a node name cannot contain a namespace. This is also said in the ROS wiki about nodes:

name="nodename" Node name. NOTE: name cannot contain a namespace. Use the ns attribute instead.

The node name is name="$(anon rviz)" This is generated in every moveit config I have seen, so I don't know why this is suddenly a problem.

I also don't understand what the ns attribute is I have to use instead...

Kind Regards, Yannik

EDIT: this is the launch file what's causes the issue on my pc (it seems that it does work on other pc's)

<launch>

  <arg name="debug" default="false" />
  <arg unless="$(arg debug)" name="launch_prefix" value="" />
  <arg     if="$(arg debug)" name="launch_prefix" value="gdb --ex run --args" />

  <arg name="config" default="false" />
  <arg unless="$(arg config)" name="command_args" value="" />
  <arg     if="$(arg config)" name="command_args" value="-d $(find epson_moveit_config)/launch/moveit.rviz" />

  <node name="$(anon rviz)" launch-prefix="$(arg launch_prefix)" pkg="rviz" type="rviz" respawn="false"
    args="$(arg command_args)" output="screen">
    <rosparam command="load" file="$(find epson_moveit_config)/config/kinematics.yaml"/>
  </node>

</launch>
edit retag flag offensive close merge delete

Comments

It doesn't look like that line is the one causing the problem. Can you add your full launch file to your question?

ahendrix gravatar image ahendrix  ( 2014-03-04 04:18:48 -0500 )edit

If this works on other machines, it's likely an issue with your machine. You may be able to get more debugging information by running roslaunch with -v

ahendrix gravatar image ahendrix  ( 2014-03-04 06:21:01 -0500 )edit

I checked the information now several times but I'm not really getting smarter from it. But I guess it's hard to help solving a problem with a machine from a distance. I think it's just really strange that it gives an error about the namespace but my pc causes it, could it be something I added to the ./bashrc?

Yannik_K gravatar image Yannik_K  ( 2014-03-04 21:47:12 -0500 )edit

Since you have working and non-working machines, I would compare the environment across both machines, and I would compare the output from roslaunch -v across machines. Feel free to add all of those to your question if you'd like a second set of eyes on them.

ahendrix gravatar image ahendrix  ( 2014-03-05 08:22:49 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-03-12 01:34:51 -0500

Yannik_K gravatar image

I think the error was caused by the fact that my key setup (when installing ROS) failed.

So after reintsalling my complete ROS hydro system, it suddenly worked. This is not an answer to the fact what caused the problem, but at my pc it solved the issue.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-04 01:12:32 -0500

Seen: 1,267 times

Last updated: Mar 12 '14