Ask Your Question
0

Unable to run gazebo 1.0.0 RC2

asked 2012-02-08 10:14:19 -0600

Capelare gravatar image

updated 2014-01-28 17:11:18 -0600

ngrennan gravatar image

Hi there,

I have just installed Ubuntu and ROS and gazebo-1.0.0-RC2 but when I run the gzserver command this is what I get:

Gazebo multi-robot simulator, version 1.0.0-RC2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Warning: no world filename specified, using default world
Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345
Segmentation fault

Is there any log or anything else where I can try and figure out what's causing the Segmentation fault?

Previous to this I was having problems, gzserver repeated this message several times:

Xlib: extension “GLX” missing on display “:0.0″. Insufficient GL support

I solved it by installing OpenGL... and that's when the Segfault appeared. So now I don't know if this introduced the current error or it has nothing to do.

Thanks for your time! Miguel.

-------------------------------------------------------------------------------

Update: My Ubuntu installation died and I had to reinstall everything... Now I'm not getting any Xlib errors or segfaults, but instead this is what's happening:

Gazebo multi-robot simulator, version 1.0.0-RC2
Copyright (C) 2011 Nate Koenig, John Hsu, Andrew Howard, and contributors.
Released under the Apache 2 License.
http://gazebosim.org

Warning: no world filename specified, using default world
Msg Waiting for master
Msg Connected to gazebo master @ http://localhost:11345
Exception [RenderEngine.cc:473] unable to find rendering system

Error [Rendering.cc:37] Failed to load the Rendering engine subsystem
unable to find rendering system
Exception [RenderEngine.cc:473] unable to find rendering system

Exception [RenderEngine.cc:473] unable to find rendering system

Exception [Sensors.cc:38] Unable to load the rendering engine

terminate called after throwing an instance of 'gazebo::common::Exception'
Aborted

I'm going to investigate, but I wanted to post it here first.

Thanks again! Miguel.

-------------------------------------------------------------------------------

Update 2:

I tried everything that I could think of, and I'm still getting those errors about the rendering system... Any ideas? :(

Thanks, Miguel.

edit retag flag offensive close merge delete

Comments

Can you please add a description of your computer hardware?
tfoote gravatar imagetfoote ( 2012-02-08 13:53:28 -0600 )edit
It's not that easy... Because I have Ubuntu 11.04 installed on a USB flash drive that I boot in different computers. And it doesn't work in any of the machines.
Capelare gravatar imageCapelare ( 2012-02-09 01:27:13 -0600 )edit
For example, right now I am on a i5-650 @ 3.2GHz with 8GB of RAM and an ATI RV730 PRO (Radeon HD 4650)...
Capelare gravatar imageCapelare ( 2012-02-09 01:45:53 -0600 )edit
Can you make a backtrace? There could be a problem in Fuerte that causes segfault with the ros wrapped gazebo. Specifically when the plugin to get package paths is invoked (e.g. see https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/trunk/gazebo/scripts/gazebo with the -p options).
hsu gravatar imagehsu ( 2012-02-09 05:44:31 -0600 )edit
I've updated the question after I've been forced to reinstall Ubuntu. Now I have a clean install of 11.10 with just the additional nVidia drivers and all the dependencies listed on the Requeriments page. And gazebo-1.0.0-RC2, of course.
Capelare gravatar imageCapelare ( 2012-02-12 00:49:54 -0600 )edit
BTW, I didn't understand very well what you said about the ros wrapped gazebo Hsu, because I don't have Fuerte installed (it's not listed as a requirement at gazebosim.org...). Right now I don't even have Electric or any other ros version!
Capelare gravatar imageCapelare ( 2012-02-12 02:44:07 -0600 )edit
(Weird... I accidentally double posted the comment and now I can't delete one without having the other deleted as well, so I'm editing this comment instead of deleting it. I think the problem is that the 6th comment is neither showed nor listed as "more comments").
Capelare gravatar imageCapelare ( 2012-02-12 03:23:49 -0600 )edit

can you post how you are starting gazebo?

hsu gravatar imagehsu ( 2012-02-22 07:12:41 -0600 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2012-02-24 08:12:10 -0600

hsu gravatar image

updated 2012-03-02 05:48:21 -0600

The instructions on gazebosim.org are for standalone system install of gazebo. (see my comment below about the ros-ified gazebo stack). Your problem above might be fixed by the updated step 2 in quick_start

source /usr/share/gazebo-[gazebo version]/setup.sh

should configure environment variables necessary for things to work correctly. In this case, your system is missing the correct OGRE_RESOURCE_PATH.

On another note, it looks like you are trying to install gazebo simulator directly on your system (outside of ros context) for using it with ROS. Let me try to clarify a little bit about the difference between the ros simulator_gazebo stack and the gazebosim project.

The ros simulator_gazebo stack wraps a hand-picked stable version of gazebo from the gazebo simulator project, and provides additional ros plugins/tools for using gazebo inside the ros environment. By installing ros-fuerte-simulator-gazebo, you don't have to worry about installing gazebo via instructions on gazebosim.org, but rather, just follow along the ros wiki tutorials. However, if you are interested in helping out with testing/developing the underlying simulator software, then proceed with the system install as described on the gazebo simulator project installation instruction page and try out the quick start steps. Note the two installs can exist side by side with some careful finessing of installation locations and system paths.

Hope this is not too confusing.

edit flag offensive delete link more

Comments

@hsu if anyone installs ros-fuerte-simulator-gazebo should they also install ros-fuerte-desktop*? and/or ros-electric-desktop? Also, the link you posted to the simulator_gazebo tutorials are way different than the ones at gazebosim... isn't ros-fuerte-simulator-gazebo the same as gazebosim?

Capelare gravatar imageCapelare ( 2012-03-02 03:44:49 -0600 )edit

Ok, I figured it out myself, but please tell me if I'm right/wrong. In order to use the simulator as it's explained at the gazebosim wiki, one should source <ros-fuerte-dir>/setup.sh and then <ros-fuerte-dir>/stacks/simulator_gazebo/gazebo/setup.bash. After that gzserver and gzclient work fine. (?)

Capelare gravatar imageCapelare ( 2012-03-02 04:26:45 -0600 )edit

sorry, I realized my earlier answer might be too confusing, so I removed the seconds part. I'll try to put this information on gazebo wiki instead. The basics are explained in the update gazebo package manifest (https://code.ros.org/svn/ros-pkg/stacks/simulator_gazebo/trunk/gazebo/manifest.xml)

hsu gravatar imagehsu ( 2012-03-02 04:53:36 -0600 )edit

Thanks! Anyway I decided to go with the ros-wrapped gazebo version because I think it'd be easier to upgrade :) So what I'm doing now is setting up the environment for ros-fuerte and for simulator_gazebo, and then I launch "rosrun gazebo gzserver" instead of gzserver directly ;-)

Capelare gravatar imageCapelare ( 2012-03-02 05:21:24 -0600 )edit

It's not confusing at all, don't worry. It's just I don't know what I really want to do, so I'm trying things out. What I want to accomplish is a Lego NXT simulator, and I thought it'd be a good idea to write plugins for gazebo (and use the NXT stack probably). So you tell me, do I want to use ROS?

Capelare gravatar imageCapelare ( 2012-03-02 06:00:33 -0600 )edit

I think I do want (and need?) to use it, and I'd like to use Fuerte and/or the newest gazebo, but I'm having problems with the whole 'lack of tutorials/documentation for these two' thing. Or maybe I'm just too clumsy to find them!

Capelare gravatar imageCapelare ( 2012-03-02 06:04:44 -0600 )edit
1

answered 2012-02-10 10:40:50 -0600

hsu gravatar image

updated 2012-02-22 09:02:36 -0600

Update:

The segmentation fault as described in ticket: compiler flag -Bsymbolic-functions has been fixed, so

sudo apt-get update
sudo apt-get upgrade

to get the latest versions of ros and simulator_gazebo which do not have the boost related segmentation fault.

edit flag offensive delete link more
0

answered 2012-02-22 09:06:25 -0600

hsu gravatar image

updated 2012-02-22 09:14:13 -0600

There is a know bug where nvidia driver 295.20 appears to also cause segfault on forking when starting gazebo, below is the backtrace for reference. By downgrading to an earlier version of nvidia driver (< 290.10) fixed it for me:

$ roslaunch pr2_gazebo pr2_empth_world.launch
....
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7f51f91c7700 (LWP 30795)]
0x00007f5239dc7c0f in _nv022tls () from /usr/lib/tls/libnvidia-tls.so.295.20
(gdb) bt
#0  0x00007f5239dc7c0f in _nv022tls () from /usr/lib/tls/libnvidia-tls.so.295.20
#1  0x00007f523ceb4a01 in ?? () from /usr/lib/libGL.so.1
#2  0x00007f52475ab5a5 in __libc_fork () at ../nptl/sysdeps/unix/sysv/linux/x86_64/../fork.c:95
#3  0x00007f52475687ab in _IO_new_proc_open (fp=0x7f522c307b20, command=0x7f522c4a0478 "ret=\"/opt/ros/electric/stacks/arm_navigation/joint_normalization_filters/default_plugins.xml\" && echo $ret", mode=<optimized out>)
    at iopopen.c:191
#4  0x00007f5247568b01 in _IO_new_popen (command=0x7f522c4a0478 "ret=\"/opt/ros/electric/stacks/arm_navigation/joint_normalization_filters/default_plugins.xml\" && echo $ret", mode=0x7f52463ccb51 "r") at iopopen.c:312
#5  0x00007f52463b85df in rospack::Package::direct_flags (this=0x7f522c07f9b0, lang=..., attrib=...) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/tools/rospack/rospack.cpp:584
#6  0x00007f52463bf800 in rospack::Package::plugins (this=0x7f522c441d10) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/tools/rospack/rospack.cpp:304
#7  0x00007f52463c0062 in rospack::ROSPack::cmd_plugins (this=0x7f51f91c57e0) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/tools/rospack/rospack.cpp:1164
#8  0x00007f52463c2fd7 in rospack::ROSPack::run (this=0x7f51f91c57e0, argc=4, argv=0x7f522c513200) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/tools/rospack/rospack.cpp:1438
#9  0x00007f52463c3826 in rospack::ROSPack::run (this=0x7f51f91c57e0, cmd=<optimized out>) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/tools/rospack/rospack.cpp:1206
#10 0x00007f5248e43f03 in ros::package::command (_cmd=...) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/core/roslib/src/package.cpp:55
#11 0x00007f5248e44245 in ros::package::command (cmd=<optimized out>, output=...) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/core/roslib/src/package.cpp:73
#12 0x00007f5248e4478b in ros::package::getPlugins (package=..., attribute=<optimized out>, plugins=...) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/core/roslib/src/package.cpp:125
#13 0x00007f5248e4537c in ros::package::getPlugins (package=<optimized out>, attribute=<optimized out>, plugins=...) at /tmp/buildd/ros-electric-ros-1.6.8/debian/ros-electric-ros/opt/ros/electric/ros/core/roslib/src/package.cpp:113
#14 0x00007f51f6733cae in pluginlib::ClassLoader<filters::FilterBase<double> >::ClassLoader (this=0x7f522c485828, package=..., base_class=..., attrib_name=...)
    at /opt/ros/electric/stacks/pluginlib/include/pluginlib/class_loader_imp.h:51
#15 0x00007f51f6726f0d in FilterChain (data_type=..., this=0x7f522c485828) at /opt/ros/electric/stacks/filters/include/filters/filter_chain.h:53
#16 controller::LaserScannerTrajController::LaserScannerTrajController (this=0x7f522c485670)
    at /tmp/buildd/ros-electric-pr2-controllers-1.6.2/debian/ros-electric-pr2-controllers/opt/ros/electric/stacks/pr2_controllers/pr2_mechanism_controllers/src/laser_scanner_traj_controller.cpp:47
#17 0x00007f51f67274e8 in controller::LaserScannerTrajControllerNode::LaserScannerTrajControllerNode (this=0x7f522c485560)
    at /tmp/buildd/ros-electric-pr2-controllers-1.6.2/debian/ros-electric-pr2-controllers/opt/ros/electric/stacks/pr2_controllers/pr2_mechanism_controllers/src/laser_scanner_traj_controller.cpp:399
#18 0x00007f51f6734e3a in Poco::MetaObject ...
(more)
edit flag offensive delete link more
0

answered 2012-02-09 04:36:57 -0600

DimitriProsser gravatar image

One thing would be that Gazebo takes a commandline argument that specifies the world file to launch. You can find them in $(gazebo_worlds)/worlds. So:

gzserver /opt/ros/electric/simulator_gazebo/gazebo_worlds/worlds/empty.world

or something along those lines.

edit flag offensive delete link more

Comments

Thanks for your answer, but I don't think that's the problem, because as far as I know if you don't provide a .world file as argument, Gazebo loads empty.world by default ;-)
Capelare gravatar imageCapelare ( 2012-02-09 04:40:46 -0600 )edit
Anyway I tried to run 'gzserver /usr/share/gazebo-1.0.0-RC2/worlds/empty.world' just in case and it kept giving a segmentation fault :(
Capelare gravatar imageCapelare ( 2012-02-09 04:41:32 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2012-02-08 10:14:19 -0600

Seen: 1,958 times

Last updated: Mar 02 '12