Ask Your Question
0

Problem capturing RGBDSLAM pointcloud data in headless mode

asked 2012-02-03 23:13:28 -0500

Mike Moore gravatar image

updated 2014-01-28 17:11:16 -0500

ngrennan gravatar image

Third RGBDSLAM question of the day... sorry :-)

In order to speed up processing (and hence hopefully improve mapping significantly) I'm running RGBDSLAM in headless mode. So, I'm trying to try generate a new .pcd file using the following command:

roslaunch rgbdslam headless.launch

(not roslaunch rgbdslam rgbdslam_headless.launch as it says in the README)

I then, in a different Terminal, execute:

rosservice call /rgbdslam/ros_ui_b pause false

to start to "capture a stream of data:" and the RGBDSLAM Terminal displays:

[ INFO] [1328358771.842035641]: Pause toggled to: false

However, the CPU load does not increase at this stage as I expected. I then try to save the pointclouds as a singe pcd file by executing:

rosservice call /rgbdslam/ros_ui save_all

But no file is generated and the RGBDSLAM Terminal displays:

[ INFO] [1328358846.008384132]: Saving Whole Model to quicksave.pcd

[ INFO] [1328358846.008732434]: Saving all clouds to quicksave.pcd, this may take a while as they need to be transformed to a common coordinate frame.

[pcl::PCDWriter::writeBinary] Input point cloud has no data!

[ INFO] [1328358846.008925177]: *Saved 0 data points to quicksave.pcd*

Am I going about this in the correct way?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2012-02-07 03:11:46 -0500

Hi Mike. Could you please copy the following line into headless.launch, so that it is enclosed in the <node></node> tag.

<param name="config/store_pointclouds" value="true"/>

Storing the pointclouds for sending them out later is convenient, though it requires a lot of memory. If you want significant improvements of quality, I'd suggest to look at the file rgbdslam_sample_config.launch. It should contain all parameters that influence accuracy and speed (mostly in tradeoffs one vs the other). If you have a GPU, try SIFTGPU feature detector and extractor to speed things up.

edit flag offensive delete link more
1

answered 2012-06-28 22:14:10 -0500

sunilsulania9192 gravatar image

I too had the same problem I tried Above solution too but could not SOLVE the problem.

The solution I found is,

You should launch openni_node before running headless. i.e.

roslaunch openni_camera openni_node.launch

and then

roslaunch rgbdslam headless.launch

edit flag offensive delete link more

Comments

2

Yeah, of course the camera driver needs to be running.

Felix Endres gravatar image Felix Endres  ( 2012-07-09 05:37:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-03 23:13:28 -0500

Seen: 747 times

Last updated: Jun 28 '12