Ask Your Question
3

Problems viewing RGBDSLAM saved PCD files with pcd_viewer

asked 2012-02-03 21:43:21 -0500

Mike Moore gravatar image

updated 2014-01-28 17:11:16 -0500

ngrennan gravatar image

Hi folks

Using RGBDSLAM I have generated a few maps (small and large) and have saved them as PCD files using the GUI. However I have not been able to subsequently view them with pcd_viewer (installed with the ros-electric-perception-pcl-addons package) using the following command (as per http://www.ros.org/wiki/openni/Contests/ROS%203D/RGBD-6D-SLAM):

rosrun pcl_visualization pcd_viewer -ax 0.1 test.pcd

as I get the following error:

> Loading test.pcd /opt/ros/electric/stacks/perception_pcl_addons/pcl_visualization/bin/pcd_viewer: symbol lookup error: /opt/ros/electric/stacks/perception_pcl_addons/pcl_visualization/bin/pcd_viewer: undefined symbol: _ZN17pcl_visualization28PCLVisualizerInteractorStyle3NewEv

I looks like the same issue is being experienced with the laser test group http://answers.ros.org/question/3686/point-cloud-viewer-not-working-why

Is anyone currently able to use pcd_viewer?

edit retag flag offensive close merge delete

Comments

Could you upload the pcd file somewhere and give the link here for us to check
karthik gravatar imagekarthik ( 2012-02-03 22:22:42 -0500 )edit
Sure thing, I'll post it shortly - but its odd that others are having the same issue with an undefined symbol - can you suggest a dependency we may be missing?
Mike Moore gravatar imageMike Moore ( 2012-02-03 22:44:18 -0500 )edit
I have pcl 1.4 standalone so i use pcd_viewer filename.pcd to view the cloud. I just wanted to check if the cloud is fine in your case.
karthik gravatar imagekarthik ( 2012-02-03 23:03:26 -0500 )edit
I just checked the pcl_visualization and even i am getting the same error using it in ros. I guess this is a bug.
karthik gravatar imagekarthik ( 2012-02-03 23:04:52 -0500 )edit
Rightio, do I need to let any team in particular know about this? Also, where do I get the standalone PCL 1.4 viewer you mentioned - its not an obvious package.
Mike Moore gravatar imageMike Moore ( 2012-02-03 23:47:28 -0500 )edit
i was talking about ROS independent PCL library installed in the system. http://pointclouds.org/downloads/
karthik gravatar imagekarthik ( 2012-02-04 04:30:36 -0500 )edit
meanwhile you can post this information in ros mailing list
karthik gravatar imagekarthik ( 2012-02-05 01:44:36 -0500 )edit

Have you tried pcl/pcd_viewer instead of pcl_visualization/pcd_viewer? For me it works.

Mchaiiann gravatar imageMchaiiann ( 2012-03-26 03:42:07 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
2

answered 2012-05-07 09:39:42 -0500

murat gravatar image

I think this is because libpcl_visualization.so files inside pcl_visualizations_addons/lib/ and pcl/lib/ are conflicting. The loader is looking for the symbol inside pcl/lib/libpcl_visualization.so whereas the symbol is actually located in the other library.

I managed to workaround this problem by replacing all occurences of pcl_visualization with pcl_visualization_addons in the following three files:

  • perception_pcl_addons/pcl_visualization/src/examples/CMakeLists.txt
  • perception_pcl_addons/pcl_visualization/src/tools/CMakeLists.txt
  • perception_pcl_addons/pcl_visualization/CMakeLists.txt
edit flag offensive delete link more
0

answered 2012-06-04 10:30:40 -0500

Chong gravatar image

I'm getting exactly the same error while I don't have such a folder named pcl_visualizations... Any ideas how to solve this?

edit flag offensive delete link more

Comments

the folder is named pcl_visualization (singular not plural)

georgebrindeiro gravatar imagegeorgebrindeiro ( 2012-12-10 00:58:55 -0500 )edit

Is this answer still relevant? I can't find a folder in my ROS/PCL installation labelled "perception_pcl_addon".

M@t gravatar imageM@t ( 2017-07-30 19:09:19 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-02-03 21:43:21 -0500

Seen: 1,456 times

Last updated: Jun 04 '12