Ask Your Question
2

Turtlebot microphone troubleshooting guide

asked 2012-01-26 04:01:15 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello all,

I've had a rather painful time getting the microphone to work on the Asus eeePC 1215n that comes with the turtlebot. I finally got everything working again, so I'll post here to save others some pain.

Hopefully others will edit this post and add their own notes.

Setup

Asus eePC 1215n running Ubuntu 10.04 that comes with the turtlebot. Latest patches installed and running ROS electric.

The microphone jack works currently, but the internal mic is misbehaving. This isn't a problem for me as I'd rather use the external anyway. If someone else has ideas on how to get this working, please post.

Basic Microphone Configuration

You need to unmute the microphone lines and select the correct profile.

  1. Open volume control properties or launch gnome-volume-control
  2. Run alsamixer and press F4 to go the input section. Make sure all lines are unmuted (press 'm' to mute/unmute) and the gain is set fairly high. Alternatively, open sound preferences or run gnome-volume-control and use the "input devices" tab to unmute / adjust levels.
  3. Install pavucontrol and configure things there.
    • apt-get install pavucontrol
    • launch pavucontrol
    • On the "configuration" tab, select "analog stereo duplex + input"
    • Go to "input devices" tab and make sure your devices are unmuted and gain is fairly high.
  4. Open sound recorder or audacity and try recording a sound to make sure the mic is working.

reference: http://tarnusdrinkscoffee.blogspot.com/2011/03/ubuntu-1010-1215n-built-in-micro.html

Advanced Troubleshooting

Ubuntu has some good resources for troubleshooting microphone problems.

https://help.ubuntu.com/community/SoundTroubleshooting">Ubuntu sound troubleshooting guide

Intel-hda specific troubleshooting

Problem: Microphone is not recording

Solution: follow the basic configuration above to unmute everything.

Problem: There's too much static

Solution:

Use alsamixer to adjust your microphone gain

Problem: I only get static on the microphone

Solution:

Try advanced troubleshooting, check to see if you see any ports or connectors under volume control and try the section below if you don't see any.

Problem: Alsa can't see my input devices

Symptoms - No "connectors" or "ports" show up under volume control even though the sliders are still there. - arecord -l lists "0/1" devices - You've tried everything else and it still doesn't work

Solution:

This is the nasty one that took me forever to solve. The microphone mysteriously stopped working after an upgrade and I couldn't figure out why.

So... you need to follow the intel-hda troubleshooting guide found above.

I solved the problem by editing /etc/modprobe.d/alsa-base.conf and adding the following line to the bottom of the file and then rebooting.

options snd-hda-intel model=basic

The above will make the mic jack work, but may not make the internal mic work.

Problem: the internal mic doesn't work, but the mic jack does

Solution: no clue, I still haven't got this to work. Try google?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2012-04-05 07:43:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

No Answer Necessary.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-26 04:01:15 -0500

Seen: 1,791 times

Last updated: Apr 05 '12