Ask Your Question
0

Turtlebot / Kinect - not publishing any images?

asked 2012-01-16 04:16:33 -0500

Murph gravatar image

updated 2016-10-24 09:00:49 -0500

ngrennan gravatar image

I've built a mostly-turtlebot. After running the turtlebotbringup minimal and kinect.launch, it seems to run fine. The topics are all created, but no image data or depth data is ever published.

The turtlebot dashboard doesn't show anything amiss.

The front of the kinect is flashing it's green light.

Any clue where to look?

I tried an alternate power supply, wall power, and an alternate kinect. So it's probably not those issues.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2012-01-23 08:43:40 -0500

Murph gravatar image

Well, here's my answer for posterity:

It was a bug in my USB drivers in the kernel.

Running the freenect demos gave a lot of: "Failed to submit isochronous transfer x: -1" And dmesg informed me that usb_submit_urb was returning -28 (ENOSPC).

Switching up my kernel versions and USB drivers made everything come to life.

Thanks for the help everyone that tried, I really appreciate it.

edit flag offensive delete link more
1

answered 2012-01-16 05:47:59 -0500

fergs gravatar image

Is the 12V line of the Kinect powered? The green LED will indicate that USB is powered, but if the 12V is not powered then the Kinect will not publish data.

edit flag offensive delete link more

Comments

Hrm, now that you mention it, there is some *really* suspect wire on this one... I'll rebuild and report back. Do you know a way to tell, in software, when this condition occurs? I could add a warning to the ros nodes.
Murph gravatar image Murph  ( 2012-01-16 06:25:05 -0500 )edit
Okay, the light on the USB splitter thing is one, and the device reports all three devices (Motor, Audio, Camera) via "lsusb" - things which I confirm do not happen if the 12v line is disconnected. So it must be powered. (Edit: Just tried wall power too, no help)
Murph gravatar image Murph  ( 2012-01-16 07:14:31 -0500 )edit
Do you see the IR-Laser (left-most lens when looking from front) turning on if you are subscribing to any depth-related topic?
Ben_S gravatar image Ben_S  ( 2012-01-16 20:16:07 -0500 )edit
0

answered 2012-01-17 02:41:03 -0500

tbh gravatar image

updated 2012-01-17 02:47:05 -0500

I've had some problems with the openni_kinect driver not publishing any image messages, and there seem to be others experiencing this problem, too. There's a bug ticket at https://kforge.ros.org/openni/trac/ticket/42 and another thread dealing more specifically with this issue here. Hopefully they'll fix it in fuerte, but in the meantime, you might try restarting the driver until you get some topics published.

edit flag offensive delete link more

Comments

A number of race conditions at startup were fixed since those discussions.
fergs gravatar image fergs  ( 2012-01-17 10:48:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-16 04:16:33 -0500

Seen: 1,270 times

Last updated: Jan 23 '12