Ask Your Question
1

problem in installing RGBD Slam

asked 2014-02-03 23:02:21 -0500

ghazaleh gravatar image

updated 2016-10-24 09:00:44 -0500

ngrennan gravatar image

I use Ubuntu 12.04 and ROS Fuerte. I want to install RGBD slam.I try above commends in my ros package path

> $svn co http://alufr-ros-pkg.googlecode.com/s...
$rosdep update

but while I type this command > rosdep install rgbdslam_freiburg I got these error

> ERROR: Rosdep cannot find all required resources to answer your query Missing resource rgbdslam_freiburg ROS path [0]=/opt/ros/fuerte/share/ros ROS path [1]=/opt/ros/fuerte/share ROS path [2]=/opt/ros/fuerte/stacks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-04 06:48:55 -0500

Vegeta gravatar image

updated 2014-02-04 06:50:35 -0500

Make sure your ros workspace is correctly defined. You should not install the rgbdslam package in opt/ros folder. The instructions on the page are very clear. Make sure your ROS environment and workspace is properly set. See this page on how to set up your ros workspace ROS workspace tutorial

edit flag offensive delete link more

Comments

a good idea is if You have created a workspace to add these lines in .basrc file: 1. source /opt/ros/fuerte/setup.bash 2. source ~/fuerte_workspace/setup.bash If You have created Your workspace and it worked and after some time reseted a computer then You "lose" path and You need to add it again (or bash it :) )

Wilk gravatar image Wilk  ( 2014-02-04 07:07:18 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-02-03 23:02:21 -0500

Seen: 680 times

Last updated: Feb 04 '14