Ask Your Question
0

turtlebot.launch location if Electric is complied from source

asked 2011-12-06 17:09:49 -0500

osuairt gravatar image

Hi all,

I am just having a problem with localization on the Turtlebot clone I have here. Firstly, where do I set the calibration parameters if I compile from source on the machine? In the Tutorials they say to change them in /etc/ros/electric, but am I right in thinking that that is only visible if I have installed from and sourced the Electric from the debs?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2011-12-22 21:10:47 -0500

mmwise gravatar image

If you want the files in /etc configure upstart

Configure Upstart

It is recommended to use Upstart to start your robot:

roscd turtlebot_bringup/upstart
sudo ./install.bash wlan0

You should replace wlan0 with the name of your wifi interface.

For Ubuntu 11.10 , install daemontools which is need by turtlebot_start.

sudo apt-get install daemontools

Setup NTP

Clock synchronization is important for ROS. Chrony has been found to be the best ntp client over lossy wireless.

manually sync NTP

sudo ntpdate ntp.ubuntu.com

Install Chrony

sudo apt-get install chrony

These are the last half of the instructions here: http://ros.org/wiki/Robots/TurtleBot/Robot%20Install

edit flag offensive delete link more

Comments

Hi Melonee, thank you. However, I did manage to get upstart installed it wasn't running as expected. So, say I reboot the Turtlebot, then tried to run teleop, there would be no movement. So, I reverted back to minimal.launch. I've a Turtlebot Clone not installed from an image.
osuairt gravatar image osuairt  ( 2012-02-07 01:00:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-06 17:09:49 -0500

Seen: 196 times

Last updated: Dec 22 '11