Ask Your Question
0

TurtleBot Calibration -- Still waiting for scan

asked 2011-09-02 06:22:10 -0500

C gravatar image

updated 2011-09-02 10:17:12 -0500

mmwise gravatar image

I've been following the turtlebot tutorial (http://www.ros.org/wiki/Robots/TurtleBot) I am stuck on 5.TurtleBot Odometry and Gyro Calibration

When I run
$ roslaunch turtlebot_calibration calibrate.launch,
I get the following output, and the final message "Still waiting for scan" repeats forever.

Any suggestions?
I am using the full kit that comes with everything (irobot, kinect, eeepc, etc).

Thanks!


turtlebot@turtlepc:~$ roslaunch turtlebot_calibration calibrate.launch
... logging to /home/turtlebot/.ros/log/ff3cc802-d58c-11e0-8856-485d607f5c5a/roslaunch-turtlepc-13025.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://192.168.22.137:60654/

SUMMARY
========

PARAMETERS
 * /rosversion
 * /rosdistro
 * /scan_to_angle/min_angle
 * /scan_to_angle/max_angle

NODES
  /
    scan_to_angle (turtlebot_calibration/scan_to_angle.py)
    turtlebot_calibration (turtlebot_calibration/calibrate.py)

ROS_MASTER_URI=http://192.168.22.137:11311

core service [/rosout] found
process[scan_to_angle-1]: started with pid [13049]
process[turtlebot_calibration-2]: started with pid [13050]
[INFO] [WallTime: 1314988172.573716] Estimating imu drift
[INFO] [WallTime: 1314988172.875424] Still waiting for imu
[INFO] [WallTime: 1314988173.176998] Still waiting for scan
[INFO] [WallTime: 1314988173.478575] Still waiting for scan
[INFO] [WallTime: 1314988173.780582] Still waiting for scan
[INFO] [WallTime: 1314988174.082496] Still waiting for scan
[INFO] [WallTime: 1314988174.384073] Still waiting for scan
[INFO] [WallTime: 1314988174.685638] Still waiting for scan
[INFO] [WallTime: 1314988174.987211] Still waiting for scan
[INFO] [WallTime: 1314988175.289460] Still waiting for scan
[INFO] [WallTime: 1314988175.591138] Still waiting for scan
[INFO] [WallTime: 1314988175.893684] Still waiting for scan
[INFO] [WallTime: 1314988176.195267] Still waiting for scan
[INFO] [WallTime: 1314988176.496867] Still waiting for scan
[INFO] [WallTime: 1314988176.798562] Still waiting for scan
edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-09-02 07:27:02 -0500

mmwise gravatar image

It sounds like your TurtleBot software on your TurtleBot might not be up to date:

sudo apt-get update

then:

sudo apt-get install ros-diamondback-turtlebot-robot
edit flag offensive delete link more

Comments

Thanks! That helped a bit. It now gets past the previous error, and the robot starts rotating. However, before completing a full turn, it stops and the wrench icon on the dashboard becomes red. Its says Power System: Error.
C gravatar image C  ( 2011-09-02 09:12:46 -0500 )edit
0

answered 2011-09-02 06:41:11 -0500

tfoote gravatar image

It sounds like the Kinect is not powered on. Can you launch the turtlebot dashboard and make sure that the turtlebot is in active mode (by clicking on the gear) and that breaker 0 is green. If not click on the gear and change it to active mode. turtlebot_dashboard documentation

edit flag offensive delete link more
0

answered 2011-09-02 09:15:54 -0500

C gravatar image

Thanks! That updating the software helped a bit. It now gets past the previous error, and the robot starts rotating. However, before completing a full turn, it stops and the wrench icon on the dashboard becomes red. Dashboard says Power System: Error. Further clicking reveals: Level: Error. Message: Error.

Below is how it looks on the terminal.

BTW, you must be Melonee from the Youtube videos. Thanks for the help! I might be asking more questions in the future.

--David


core service [/rosout] found
process[kinect_breaker_enabler-1]: started with pid [7908]
process[openni_manager-2]: started with pid [7909]
process[openni_camera-3]: started with pid [7910]
process[pointcloud_throttle-4]: started with pid [7911]
process[kinect_laser-5]: started with pid [7912]
process[kinect_laser_narrow-6]: started with pid [7923]
process[scan_to_angle-7]: started with pid [7940]
process[turtlebot_calibration-8]: started with pid [7952]
[INFO] [WallTime: 1314997822.154698] Estimating imu drift
[INFO] [WallTime: 1314997822.456846] Still waiting for imu
[INFO] [WallTime: 1314997822.759576] Still waiting for scan
[ INFO] [1314997822.951332371]: [/openni_camera] Number devices connected: 1
[ INFO] [1314997822.952506928]: [/openni_camera] 1. device on bus 001:31 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'A00364A10656048A'
[ WARN] [1314997822.959441340]: [/openni_camera] device_id is not set! Using first device.
[ INFO] [1314997823.019817499]: [/openni_camera] Opened 'Xbox NUI Camera' on bus 1:31 with serial number 'A00364A10656048A'
[kinect_breaker_enabler-1] process has finished cleanly.
log file: /home/turtlebot/.ros/log/2f26eecc-d5a5-11e0-b536-485d607f5c5a/kinect_breaker_enabler-1*.log
[ INFO] [1314997823.164011946]: rgb_frame_id = 'kinect_rgb_optical_frame' 
[ INFO] [1314997823.181211203]: depth_frame_id = 'kinect_depth_optical_frame' 
[INFO] [WallTime: 1314997833.370081] Still waiting for imu
[INFO] [WallTime: 1314997833.672666] Still waiting for scan
[INFO] [WallTime: 1314997833.974910]  ... imu drift is -0.243444 degrees per second
[INFO] [WallTime: 1314997833.976291] Aligning base with wall
[INFO] [WallTime: 1314997834.279068] Still waiting for imu
[INFO] [WallTime: 1314997834.581917] Still waiting for scan

edit flag offensive delete link more

Comments

1
does the battery item say error? double click on item in the power system list that has an error.. It sounds like your battery might be dying... when you double click on the battery item what is the voltage it's reporting?
mmwise gravatar image mmwise  ( 2011-09-02 09:46:12 -0500 )edit
I tried it again after charging for a while and it works now! It may have been the battery. The voltage now is 15.084V. What is a proper operating range? Thanks a lot!!!
C gravatar image C  ( 2011-09-02 10:53:57 -0500 )edit
typically the irobot create will shutdown when the voltage is around 12-13V and the kinect is running. Completely charged the voltage should be about 17V.
mmwise gravatar image mmwise  ( 2011-09-02 10:59:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-02 06:22:10 -0500

Seen: 973 times

Last updated: Sep 02 '11