ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
4

Complaint from openni_launch on already advertised services

asked 2011-12-06 09:23:03 -0500

NeuralJuiceBox gravatar image

updated 2016-10-24 09:00:39 -0500

ngrennan gravatar image

[ERROR] [1323213598.693718118]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/compressed/set_parameters] [ERROR] [1323213598.725968778]: Tried to advertise a service that is already advertised in this node [/camera/depth_registered/image_rect_raw/theora/set_parameters]/image_rect_raw/theora/set_parameters]

This appears after the processes have started up when I run.

roslaunch openni_launch openni.launch

What am I doing wrong here?

Thanks in advance.

edit retag flag offensive close merge delete

Comments

Maybe a previous run had not shut down completely? Was roscore still running from before?
joq gravatar imagejoq ( 2011-12-06 11:10:11 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
6

answered 2011-12-06 13:35:28 -0500

Patrick Mihelich gravatar image

updated 2011-12-06 20:30:53 -0500

Eric Perko gravatar image

You are not doing anything wrong. This is a bug with plugins to image_transport - under the right conditions their dynamic_reconfigure services can collide, producing those errors. It's ticketed at https://code.ros.org/trac/ros-pkg/ticket/4883 .

The error output is annoying but in practice doesn't cause much harm, so this has been a low-priority item.

edit flag offensive delete link more

Comments

Appreciated.
NeuralJuiceBox gravatar imageNeuralJuiceBox ( 2011-12-06 14:39:32 -0500 )edit

So, If i download the path will that error go away?

freadx gravatar imagefreadx ( 2013-03-17 22:32:18 -0500 )edit

As suggested I ignored the error for the time being, But unable to see the image in RVIZ using Image panel. Pls help

lifelonglearner gravatar imagelifelonglearner ( 2014-01-28 14:04:47 -0500 )edit
14

answered 2012-05-14 14:38:45 -0500

updated 2012-05-14 22:52:11 -0500

Actually, I found out how to get rid of that annoying error message. The reason for that error is that really roslaunch openni_launch openni.launch is trying to publish twice some of the topics.

I am using ROS Electric, but I think the following also applies to Fuerte:

Taking a look at the file openni.launch one can see that, among other things, it includes another launch file

<include file="$(find openni_launch)/launch/includes/device.launch">

Then, the file device.launch includes (very elegantly) some other launch files

<include file="$(find openni_launch)/launch/includes/rgb.launch" ns="$(arg rgb)">
<include file="$(find openni_launch)/launch/includes/ir.launch" ns="$(arg rgb)">
<include file="$(find openni_launch)/launch/includes/depth.launch" ns="$(arg rgb)">
<include file="$(find openni_launch)/launch/includes/depth_registered.launch" ns="$(arg rgb)">
...

The problem is that the launch file depth_registered.launch includes again the launch file depth.launch, but this time with a flag to disable the generation of the point_xyz generation. I don't know why it is doing it, I see no reason for it considering that depth.launch is already running.

So, a workaround to the error of this post is to comment out the following from the depth_registered.launch file

<!-- Get all the usual depth topics -->
<include file="$(find openni_launch)/launch/includes/depth.launch"
   ns="$(arg depth_registered)">
    <arg name="manager"    value="$(arg manager)" />
    <arg name="points_xyz" value="false" /> 
    <arg name="bond" value="$(arg bond)" />
</include>

If you comment those lines, the error goes away and everything seems to work just fine.

I hope this could be helpful for you too.

edit flag offensive delete link more

Comments

Thanks for helping get rid of the annoying error messages.

harsha gravatar imageharsha ( 2012-09-21 06:02:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2011-12-06 09:23:03 -0500

Seen: 6,937 times

Last updated: Apr 20 '14