Ask Your Question
0

ros.properties is missing

asked 2011-12-05 02:09:34 -0600

Poseidonius gravatar image

Mmmh, I become crazy ! I followed the wiki of rosjava but when I do rosmake I get the message

/home/.../my_demo/build.xml:21: ros.properties is missing.  Please type 'rosmake' first

What I have to do?

Poseidonius

edit retag flag offensive close merge delete

Comments

Have you rosmaked rosjava (separately)? I think there needs to be some bootstrapping first.
Felix Endres gravatar imageFelix Endres ( 2011-12-05 02:41:29 -0600 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2012-01-01 01:58:13 -0600

ROSJava generates the file ros.properties. To generate it is necessary to execute the command rosmake but in the case of rosjava, it is necessary to udpate the file makefile with the following line:

include $(shell rospack find rosjava_bootstrap)/rosjava.mk

Cheers

Juan Antonio

edit flag offensive delete link more

Comments

I've done this, and followed the webpage instructions exactly (started over multiple times as well). ros.properties is there, yet I still get this error.
morrowsend gravatar imagemorrowsend ( 2012-01-22 10:55:42 -0600 )edit
0

answered 2012-04-03 23:46:57 -0600

rosdai gravatar image

updated 2012-04-03 23:49:05 -0600

same problem here

 rosrun rosjava_bootstrap generate_properties.py my_package > ros.properties
  if [ ! -f .project ] ; then sed s/PROJECT_NAME/my_package/ `rospack find rosjava_bootstrap`/eclipse/eclipse-project-template > .project ; touch .project-generated; fi
  if [ ! -f .classpath ] ; then rosrun rosjava_bootstrap generate_properties.py --eclipse my_package > .classpath ; touch .classpath-generated; fi
  rosrun rosjava_bootstrap generate_msg_depends.py my_package
  ant
  Buildfile: /home/evelyn/ros_workspace/my_package/build.xml
       [echo] /home/evelyn/ros_workspace/my_package/${ros.compile.classpath}

  init:

  BUILD FAILED
  /home/evelyn/ros_workspace/my_package/build.xml:19: ros.properties is missing.  Please type 'rosmake' first

  Total time: 0 seconds
edit flag offensive delete link more
0

answered 2012-02-27 22:04:37 -0600

michikarg gravatar image

Hi,

i have the same problem here when trying to build stanford_parser_ros ... Did you find a solution yet?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-05 02:09:34 -0600

Seen: 176 times

Last updated: Apr 03 '12